aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/fzy/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/testing/fzy/APKBUILD b/testing/fzy/APKBUILD
index e094c611be..e43601c849 100644
--- a/testing/fzy/APKBUILD
+++ b/testing/fzy/APKBUILD
@@ -1,32 +1,29 @@
# Contributor: Jonathan Neuschäfer <j.neuschaefer@gmx.net>
+# Maintainer: Eivind Uggedal <eu@eju.no>
pkgname=fzy
pkgver=1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A better fuzzy finder"
url="https://github.com/jhawthorn/$pkgname"
arch="all"
license="MIT"
-depends=""
-makedepends=""
-install=""
+checkdepends="ruby-minitest ruby-ttytest"
subpackages="$pkgname-doc"
source="https://github.com/jhawthorn/fzy/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make PREFIX="/usr"
}
check() {
- cd "$builddir"
make check
- # In addition, we could also require ruby here, and run "make acceptance".
+ cd test/acceptance
+ ruby acceptance_test.rb
}
package() {
- cd "$builddir"
make install PREFIX="/usr" DESTDIR="$pkgdir"
}