aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ocaml-camlp4/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index ef0bc96282..4b15c0ceae 100644
--- a/community/ocaml-camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -4,10 +4,10 @@
pkgname=ocaml-camlp4
_pkgname=camlp4
# NOTE: camlp4 version must match ocaml version!
-pkgver=4.07.1
+pkgver=4.08.1
_pkgver="${pkgver%.*}+${pkgver##*.}"
_ocamlver=${pkgver%.*}
-pkgrel=1
+pkgrel=0
pkgdesc="Caml preprocessor and pretty-printer"
url="https://github.com/ocaml/camlp4/releases"
arch="aarch64 ppc64le x86_64" # reflect ocaml aport platforms
@@ -23,8 +23,6 @@ source="$pkgname-$_pkgver.tar.gz::https://github.com/ocaml/$_pkgname/archive/$_p
builddir="$srcdir/$_pkgname-${_pkgver/+/-}"
build() {
- cd "$builddir"
-
./configure \
--bindir="/usr/bin" \
--libdir="/usr/lib/ocaml" \
@@ -33,8 +31,6 @@ build() {
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" \
install install-META
}
@@ -57,4 +53,4 @@ dev() {
rmdir "$subpkgdir"/$sitelib 2>/dev/null || true
}
-sha512sums="330d7f7a8ea6022df2d931a67e902f2e8bbf1026fbde08e1fd216763641a33005fde51b3b785363a05aa6717180f63b349badc1c107e05d13143b0db0e7051bc ocaml-camlp4-4.07+1.tar.gz"
+sha512sums="1f8d6df42935ecdbed96a7b02d05564665b4bf0cbe4f5fd1800a1f292d8b3864d973df1e9e8c566c0fd00b5a55ba47ecd9bd07f134a9be83601e010b0246e075 ocaml-camlp4-4.08+1.tar.gz"