aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/mtd-utils/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/mtd-utils/APKBUILD b/community/mtd-utils/APKBUILD
index 36396d1887..6b52c0eff0 100644
--- a/community/mtd-utils/APKBUILD
+++ b/community/mtd-utils/APKBUILD
@@ -49,8 +49,14 @@ build() {
make
}
+_cat_found_file() {
+ local _rc="$?"
+ find -name "$1" -type f -ls -printf '%P {{{\n' -exec cat -v -n '{}' ';' -printf '}}} %P\n'
+ return "$_rc"
+}
+
check() {
- make check
+ make check || _cat_found_file 'test-suite.log'
}
flash() {