aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/rutorrent/APKBUILD (renamed from testing/rutorrent/APKBUILD)18
-rw-r--r--community/rutorrent/rutorrent.post-install (renamed from testing/rutorrent/rutorrent.post-install)0
-rw-r--r--community/rutorrent/rutorrent.pre-install (renamed from testing/rutorrent/rutorrent.pre-install)0
3 files changed, 7 insertions, 11 deletions
diff --git a/testing/rutorrent/APKBUILD b/community/rutorrent/APKBUILD
index 738cd8fc65..6729557edd 100644
--- a/testing/rutorrent/APKBUILD
+++ b/community/rutorrent/APKBUILD
@@ -1,5 +1,5 @@
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+# Contributor: Francesco Colis_ta <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=rutorrent
pkgver=3.7
pkgrel=2
@@ -8,30 +8,26 @@ url="http://code.google.com/p/rutorrent/"
arch="noarch"
license="GPL"
depends="php5 curl"
-depends_dev=""
-
# we need to user gnu tar since the permissions on files in tar archive are
# bad
makedepends="tar"
-
pkggroups="rutorrent"
install="$pkgname.pre-install $pkgname.post-install"
subpackages=""
source="http://dl.bintray.com/novik65/generic/ruTorrent-$pkgver.zip"
-_builddir="$srcdir"/ruTorrent-master
-
+builddir="$srcdir"/ruTorrent-master
build() {
- cd "$_builddir"
- chmod -R u+w "$_builddir"
+ cd "$builddir"
+ chmod -R u+w "$builddir"
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -d $pkgdir/usr/share/webapps/$pkgname
install -d $pkgdir/var/www/localhost/htdocs/
cp -r * $pkgdir/usr/share/webapps/$pkgname
- chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
+ chgrp -R rutorrent $pkgdir/usr/share/webapps/$pkgname/share
chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/settings
chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/torrents
chmod 0775 $pkgdir/usr/share/webapps/$pkgname/share/users
diff --git a/testing/rutorrent/rutorrent.post-install b/community/rutorrent/rutorrent.post-install
index 05ce03e90c..05ce03e90c 100644
--- a/testing/rutorrent/rutorrent.post-install
+++ b/community/rutorrent/rutorrent.post-install
diff --git a/testing/rutorrent/rutorrent.pre-install b/community/rutorrent/rutorrent.pre-install
index 2c539f62fd..2c539f62fd 100644
--- a/testing/rutorrent/rutorrent.pre-install
+++ b/community/rutorrent/rutorrent.pre-install