aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/openlibm/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/openlibm/APKBUILD b/testing/openlibm/APKBUILD
new file mode 100644
index 0000000000..9d83adc7b8
--- /dev/null
+++ b/testing/openlibm/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=openlibm
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="High quality system independent, portable, open source libm implementation"
+url="http://www.openlibm.org"
+arch="all"
+license="MIT BSD public-domain"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/JuliaLang/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make VERSION=$pkgver DESTDIR="$pkgdir" prefix=/usr install
+}
+
+md5sums="61db4c16f3d83b45f93ace381bab64cc openlibm-0.5.1.tar.gz"
+sha256sums="782a77497071cc450af176bbfebb34834334f6a17de842fe75cd407bbee89f85 openlibm-0.5.1.tar.gz"
+sha512sums="462f6dd6544d61f4afc8cbf622b022f588e49cd3b780df1c17e49bcc29adab58ccf33a92f410cc991a1cdb115f059736ed0eb4e8359390c9000af9c66b1bf5ff openlibm-0.5.1.tar.gz"