aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/chrpath/APKBUILD34
1 files changed, 12 insertions, 22 deletions
diff --git a/main/chrpath/APKBUILD b/main/chrpath/APKBUILD
index 27622974d0..c36eef68b4 100644
--- a/main/chrpath/APKBUILD
+++ b/main/chrpath/APKBUILD
@@ -1,30 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=chrpath
pkgver=0.16
-pkgrel=0
+pkgrel=1
pkgdesc="Modify rpath of compiled programs"
url="https://alioth.debian.org/projects/chrpath/"
arch="all"
license="GPL+"
-depends=""
-makedepends=""
-install=""
subpackages="$pkgname-doc"
source="https://alioth.debian.org/frs/download.php/latestfile/813/chrpath-$pkgver.tar.gz"
-_builddir="$srcdir"/chrpath-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,17 +20,19 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" docdir=/usr/share/doc/$pkgname-$pkgver \
- install || return 1
+ install
}
-md5sums="2bf8d1d1ee345fc8a7915576f5649982 chrpath-0.16.tar.gz"
-sha256sums="bb0d4c54bac2990e1bdf8132f2c9477ae752859d523e141e72b3b11a12c26e7b chrpath-0.16.tar.gz"
sha512sums="aa04d490f78bff20a56fe20539cec10218c0772a668909eda8324ca825f51e8ef92001e95d9c316e79a145a043c9c327ec94d1a82e104ab408ca1021832745aa chrpath-0.16.tar.gz"