aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libinput/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/main/libinput/APKBUILD b/main/libinput/APKBUILD
index 1a3e5dfb80..538e50c822 100644
--- a/main/libinput/APKBUILD
+++ b/main/libinput/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=libinput
-pkgver=1.11.3
+pkgver=1.12.4
pkgrel=0
pkgdesc="Library for handling input devices"
url="https://www.freedesktop.org/wiki/Software/libinput"
@@ -9,13 +9,13 @@ arch="all"
license="MIT"
makedepends="eudev-dev libevdev-dev meson mtdev-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-options="!check"
source="https://freedesktop.org/software/libinput/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
meson --prefix=/usr \
+ --libdir=lib \
-Ddocumentation=false \
-Dlibwacom=false \
-Ddebug-gui=false \
@@ -23,9 +23,14 @@ build() {
ninja -C builddir/
}
+check() {
+ cd "$builddir/builddir"
+ ninja test
+}
+
package() {
cd "$builddir"
DESTDIR="$pkgdir" ninja -C builddir/ install
}
-sha512sums="5e18daab6202bcbfddeebc35dac4cabb5f726b5b73f5fc87975b58f3019a54a4b1f506a3200e920638ddddfb978a0b96c23c2e90b081942f86d33c16d4836949 libinput-1.11.3.tar.xz"
+sha512sums="4e43ed5213059a481e5a73549c8325e5729d08512c4f580b924d4338a1b69dabd77fb612bec418f294c1da96c738ce26e45f8de8fbc222ab1af71a1535b3240f libinput-1.12.4.tar.xz"