aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/eventlog/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/main/eventlog/APKBUILD b/main/eventlog/APKBUILD
index 5da9ca075a..0aec432349 100644
--- a/main/eventlog/APKBUILD
+++ b/main/eventlog/APKBUILD
@@ -3,25 +3,27 @@
pkgname=eventlog
pkgver=0.2.13
-pkgrel=0
+pkgrel=1
pkgdesc="API to format and send structured log messages"
arch="all"
-url="http://www.balabit.com/support/community/products/"
+url="https://www.balabit.com/support/community/products/"
license="BSD-3-Clause"
-depends=
makedepends="automake autoconf libtool"
subpackages="$pkgname-dev"
source="https://src.fedoraproject.org/lookaside/extras/$pkgname/${pkgname}_${pkgver}.tar.gz/68ec8d1ea3b98fa35002bb756227c315/${pkgname}_${pkgver}.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ autoreconf -vif
+}
build() {
cd "$builddir"
- autoreconf -vif
./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make
}