aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-funcy/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-funcy/APKBUILD b/testing/py3-funcy/APKBUILD
new file mode 100644
index 0000000000..ab889fcb8d
--- /dev/null
+++ b/testing/py3-funcy/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-funcy
+_pkgname=funcy
+pkgver=1.10.3
+pkgrel=0
+pkgdesc="A fancy and practical functional tools"
+url="https://github.com/Suor/funcy"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+checkdepends="py3-pytest py3-whatever"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Suor/funcy/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 -m pytest .
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3ea72a596818b9bc8f89bf002634f595859588e5a2558416ceffa5703db60880c7fbaef8c0f9654b5d7d70b58e3b7282b53c295218d540dbc2a8a5b481562bb4 py3-funcy-1.10.3.tar.gz"