aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pystache/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-pystache/APKBUILD b/testing/py3-pystache/APKBUILD
index dfd5fced34..5e20ee3996 100644
--- a/testing/py3-pystache/APKBUILD
+++ b/testing/py3-pystache/APKBUILD
@@ -5,7 +5,7 @@
pkgname=py3-pystache
_realname=pystache
pkgver=0.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="Pystache is a Python implementation of Mustache."
url="https://pypi.python.org/pypi/pystache"
arch="noarch"
@@ -23,9 +23,10 @@ build() {
check() {
# This package uses 2to3 to convert itself to Python 3 on the fly
# So we need to jump through some hoops here
+ local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
mkdir -p test_dir
python3 setup.py install --root=test_dir
- PYTHONPATH=test_dir/usr/lib/python3.7/site-packages test_dir/usr/bin/pystache-test
+ PYTHONPATH=test_dir/usr/lib/python$_py3ver/site-packages test_dir/usr/bin/pystache-test
}
package() {