aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/octave/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/octave/APKBUILD b/testing/octave/APKBUILD
index b3e638f284..089b6cff68 100644
--- a/testing/octave/APKBUILD
+++ b/testing/octave/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer:
pkgname=octave
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A high-level language, primarily intended for numerical computations"
url="https://www.gnu.org/software/octave/"
arch="all !s390x"
license="GPL-3.0"
depends=""
subpackages="$pkgname-doc"
-makedepends="autoconf automake bison curl fftw-dev fltk-dev fontconfig-dev
+makedepends="autoconf automake libtool bison curl fftw-dev fltk-dev fontconfig-dev
freetype-dev gfortran glu-dev gnuplot imagemagick-dev hdf5-dev
lapack-dev libsm-dev libltdl lcms2-dev pcre-dev perl pkgconf qt-dev
readline-dev texinfo zlib-dev"
@@ -26,6 +26,7 @@ prepare() {
cd "$builddir"
find -name \*.cc -o -name \*.h -o -name \*.yy | xargs sed -i -e 's/#include <c\(math\|stdlib\)>/#include <\1.h>/'
find -name \*.h -o -name \*.cc | xargs sed -i -e 's/<config.h>/"config.h"/' -e 's/<base-list.h>/"base-list.h"/'
+ autoreconf -vif
}
build() {