aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/perl-statistics-descriptive/APKBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/testing/perl-statistics-descriptive/APKBUILD b/testing/perl-statistics-descriptive/APKBUILD
index 7126095162..418e5258d9 100644
--- a/testing/perl-statistics-descriptive/APKBUILD
+++ b/testing/perl-statistics-descriptive/APKBUILD
@@ -4,34 +4,34 @@
pkgname=perl-statistics-descriptive
_pkgreal=Statistics-Descriptive
pkgver=3.0702
-pkgrel=0
+pkgrel=1
pkgdesc="Module of basic descriptive statistical functions."
-url="http://search.cpan.org/dist/Statistics-Descriptive/"
+url="https://metacpan.org/release/Statistics-Descriptive"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-list-moreutils perl-module-build perl-test-pod perl-test-pod-coverage"
-cpanmakedepends=""
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- perl Build.PL installdirs=vendor || return 1
+ perl Build.PL installdirs=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- ./Build && ./Build test
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ ./Build
+}
+
+check() {
+ ./Build test
}
package() {
- cd "$_builddir"
- ./Build install destdir="$pkgdir" || return 1
+ ./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}