aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/marisa-trie/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/marisa-trie/APKBUILD b/testing/marisa-trie/APKBUILD
new file mode 100644
index 0000000000..3319201868
--- /dev/null
+++ b/testing/marisa-trie/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=marisa-trie
+pkgver=0.2.5
+pkgrel=0
+pkgdesc="Static and space-efficient trie data structure library"
+url="https://github.com/s-yata/marisa-trie"
+arch="all"
+license="BSD-2-Clause"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/s-yata/marisa-trie/archive/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ autoreconf -i
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --enable-sse2
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="62975a2dacd2a1072c990cd490f866cd5483c069c94a4706baf3ffc21ec43991583a8ef8721c3b841617b0654cbb894698c19759ff12b8887b6fd28939dfb547 marisa-trie-0.2.5.tar.gz"