aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/mono/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
index 1b44947b25..002bb377d6 100644
--- a/testing/mono/APKBUILD
+++ b/testing/mono/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer:
pkgname=mono
pkgver=4.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
url="http://www.mono-project.com/"
-arch="x86_64"
+arch="all"
license="GPL"
-depends=""
+depends="python"
depends_dev="zlib-dev libgdiplus-dev"
makedepends="$depends_dev python linux-headers paxmark autoconf automake libtool"
install=""
@@ -28,7 +28,9 @@ prepare() {
build() {
cd "$_builddir"
- # supplied configure has linker issues with make install
+ # set the minimum arch for x86 to prevent atmomic linker errors
+ [ "$CARCH" = "x86" ] && export CFLAGS="$CFLAGS -march=i586 -mtune=generic"
+ # autogen to fix supplied configure linker issues with make install
./autogen.sh \
--build=$CBUILD \
--host=$CHOST \
@@ -51,6 +53,8 @@ build() {
package() {
cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
+ # mark all bins
+ paxmark -mr "$pkgdir"/usr/bin/*
rm -f "$pkgdir"/usr/lib/*.la
}