aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/bind/APKBUILD41
-rw-r--r--main/bind/bind.confd10
-rw-r--r--main/bind/bind.initd79
-rw-r--r--main/bind/bind.post-install5
-rw-r--r--main/bind/bind.pre-install3
-rw-r--r--testing/bind/APKBUILD122
-rw-r--r--testing/bind/bind.127.zone11
-rw-r--r--testing/bind/bind.conf53
-rw-r--r--testing/bind/bind.confd8
-rw-r--r--testing/bind/bind.initd90
-rw-r--r--testing/bind/bind.localhost.zone11
-rw-r--r--testing/bind/bind.named.ca85
-rw-r--r--testing/bind/bind.pre-install6
-rw-r--r--testing/bind/bind.so_bsdcompat.patch11
14 files changed, 105 insertions, 430 deletions
diff --git a/main/bind/APKBUILD b/main/bind/APKBUILD
index 994d3718e5..c2c81775fd 100644
--- a/main/bind/APKBUILD
+++ b/main/bind/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bind
-pkgver=9.8.1_p1
+pkgver=9.9.0
_ver=${pkgver%_p*}
_p=${pkgver#*_p}
[ "$_p" != "$pkgver" ] && _ver="${_ver}-P$_p"
@@ -11,8 +11,10 @@ url="http://www.isc.org"
arch="all"
license="as-is"
depends=
+pkgusers="named"
+pkggroups="named"
makedepends="openssl-dev perl"
-install="$pkgname.pre-install $pkgname.post-install"
+install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs $pkgname-tools"
source="http://ftp.isc.org/isc/bind9/${_ver}/bind-${_ver}.tar.gz
bind.so_bsdcompat.patch
@@ -66,16 +68,31 @@ build() {
package() {
cd "$_builddir"
+ install -d -m0770 -g named -o root "$pkgdir"/var/bind \
+ "$pkgdir"/var/bind/sec \
+ "$pkgdir"/var/bind/dyn \
+ "$pkgdir"/var/run/named \
+ "$pkgdir"/var/log/named \
+ || return 1
+
+ install -d -m0750 -g named -o root "$pkgdir"/etc/bind \
+ "$pkgdir"/var/bind/pri || return 1
+
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la || return 1
- install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/named || return 1
- install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/named || return 1
- install -Dm644 "$srcdir"/$pkgname.conf "$pkgdir"/etc/bind/named.conf || return 1
- install -Dm644 "$srcdir"/$pkgname.named.ca "$pkgdir"/var/bind/named.ca || return 1
- install -Dm644 "$srcdir"/$pkgname.127.zone "$pkgdir"/var/bind/pri/127.zone || return 1
- install -Dm644 "$srcdir"/$pkgname.localhost.zone "$pkgdir"/var/bind/pri/localhost.zone || return 1
- mkdir -p "$pkgdir"/var/bind/sec || return 1
+ install -Dm755 "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/named || return 1
+ install -Dm644 "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/named || return 1
+ install -Dm644 "$srcdir"/$pkgname.conf \
+ "$pkgdir"/etc/bind/named.conf || return 1
+ install -Dm644 "$srcdir"/$pkgname.named.ca \
+ "$pkgdir"/var/bind/named.ca || return 1
+ install -Dm644 "$srcdir"/$pkgname.127.zone \
+ "$pkgdir"/var/bind/pri/127.zone || return 1
+ install -Dm644 "$srcdir"/$pkgname.localhost.zone \
+ "$pkgdir"/var/bind/pri/localhost.zone || return 1
cd "$pkgdir"/var/bind
ln -s named.ca root.cache || return 1
}
@@ -95,10 +112,10 @@ tools() {
done
}
-md5sums="afa41f8203d50bedad65071f9b6f96d7 bind-9.8.1-P1.tar.gz
+md5sums="9281d0b04f711d28153ba1ab04a54026 bind-9.9.0.tar.gz
f270a5b0a28ab6e818840c5c368ddbcc bind.so_bsdcompat.patch
-92914193cc603d8d81ef00534ce9c1c9 bind.initd
-8b05a287976d66d51c18b73ee7523671 bind.confd
+da52267d5d56317d08c0fb170fc14da8 bind.initd
+418a367cecfdf8760c92235d3967867e bind.confd
be5fd752bdbd59385f2a559d603098d5 bind.conf
a7455b009b7fccd74ac6f6eaa6902a00 bind.127.zone
c3220168fabfb31a25e8c3a545545e34 bind.localhost.zone
diff --git a/main/bind/bind.confd b/main/bind/bind.confd
index 82d3763509..a9af5676f7 100644
--- a/main/bind/bind.confd
+++ b/main/bind/bind.confd
@@ -2,13 +2,7 @@
OPTS=""
# Set this to the number of processors you have.
-CPU="1"
-
-# User which named should run as
-USER="named"
-
-# Default pid file location
-PIDFILE="/var/run/named/named.pid"
+# CPU="1"
# Scheduling priority: 19 is the lowest and -20 is the highest.
-NICELEVEL="0"
+# NICELEVEL="0"
diff --git a/main/bind/bind.initd b/main/bind/bind.initd
index 3284ec853a..fa9ffb3434 100644
--- a/main/bind/bind.initd
+++ b/main/bind/bind.initd
@@ -1,7 +1,15 @@
#!/sbin/runscript
-NAME=named
-DAEMON=/usr/sbin/$NAME
+extra_commands="checkconfig checkzones"
+extra_started_commands="reload"
+
+depend() {
+ need net
+ use logger
+ provide dns
+}
+
+: ${NAMED_CONF:=/etc/bind/named.conf}
depend() {
need net
@@ -10,16 +18,73 @@ depend() {
provide dns
}
+_get_pidfile() {
+ [ -n "${PIDFILE}" ] || PIDFILE=$(\
+ /usr/sbin/named-checkconf -p ${NAMED_CONF} | grep 'pid-file' | cut -d\" -f2)
+ [ -z "${PIDFILE}" ] && PIDFILE=/var/run/named/named.pid
+}
+
+checkconfig() {
+ ebegin "Checking named configuration"
+
+ if [ ! -f "${NAMED_CONF}" ] ; then
+ eerror "No ${NAMED_CONF} file exists!"
+ return 1
+ fi
+
+ /usr/sbin/named-checkconf ${NAMED_CONF} || {
+ eerror "named-checkconf failed! Please fix your config first."
+ return 1
+ }
+ eend 0
+ return 0
+}
+
+checkzones() {
+ ebegin "Checking named configuration and zones"
+ /usr/sbin/named-checkconf -z -j ${NAMED_CONF}
+ eend $?
+}
+
start() {
- ebegin "Starting ${NAME}"
- start-stop-daemon --start --quiet --background \
- --exec ${DAEMON} --nicelevel ${NICELEVEL} \
- -- -u ${USER} -n ${CPU} ${OPTS}
+ local piddir
+ ebegin "Starting named"
+ _get_pidfile
+ piddir="${PIDFILE%/*}"
+ if [ ! -d "${piddir}" ]; then
+ checkpath -q -d -o root:named -m 0770 "${piddir}" || {
+ eend 1
+ return 1
+ }
+ fi
+
+ checkconfig || { eend 1; return 1; }
+
+ # create piddir (usually /var/run/named) if necessary, bug 334535
+ _get_pidfile
+ piddir="${PIDFILE%/*}"
+ if [ ! -d "${piddir}" ]; then
+ checkpath -q -d -o root:named -m 0770 "${piddir}" || {
+ eend 1
+ return 1
+ }
+ fi
+
+ # In case someone have $CPU set in /etc/conf.d/named
+ if [ -n "${CPU}" ] && [ "${CPU}" -gt 0 ]; then
+ CPU="-n ${CPU}"
+ fi
+
+ start-stop-daemon --start --pidfile ${PIDFILE} \
+ --nicelevel ${NICELEVEL:-0} \
+ --exec /usr/sbin/named \
+ -- -u named ${CPU} ${OPTS}
eend $?
}
stop() {
- ebegin "Stopping ${NAME}"
+ ebegin "Stopping named"
start-stop-daemon --stop --quiet --pidfile $PIDFILE
eend $?
}
+
diff --git a/main/bind/bind.post-install b/main/bind/bind.post-install
deleted file mode 100644
index 7e091c097c..0000000000
--- a/main/bind/bind.post-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-install -dD -o named -g named /var/run/named
-chown -R named:named /var/bind
-
diff --git a/main/bind/bind.pre-install b/main/bind/bind.pre-install
index c799634502..e0a615ef08 100644
--- a/main/bind/bind.pre-install
+++ b/main/bind/bind.pre-install
@@ -1,5 +1,6 @@
#!/bin/sh
-adduser -h /etc/bind -s /bin/false -D named 2>/dev/null
+addgroup -S named 2>/dev/null
+adduser -h /etc/bind -s /bin/false -G named -D named 2>/dev/null
exit 0
diff --git a/testing/bind/APKBUILD b/testing/bind/APKBUILD
deleted file mode 100644
index c2c81775fd..0000000000
--- a/testing/bind/APKBUILD
+++ /dev/null
@@ -1,122 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=bind
-pkgver=9.9.0
-_ver=${pkgver%_p*}
-_p=${pkgver#*_p}
-[ "$_p" != "$pkgver" ] && _ver="${_ver}-P$_p"
-pkgrel=0
-pkgdesc="BIND - Berkeley Internet Name Domain - Name Server and tools"
-url="http://www.isc.org"
-arch="all"
-license="as-is"
-depends=
-pkgusers="named"
-pkggroups="named"
-makedepends="openssl-dev perl"
-install="$pkgname.pre-install"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-libs $pkgname-tools"
-source="http://ftp.isc.org/isc/bind9/${_ver}/bind-${_ver}.tar.gz
- bind.so_bsdcompat.patch
- $pkgname.initd
- $pkgname.confd
- $pkgname.conf
- $pkgname.127.zone
- $pkgname.localhost.zone
- $pkgname.named.ca
- "
-
-_builddir="$srcdir/bind-${_ver}"
-
-prepare() {
- cd "$_builddir"
-
- ### http://bugs.gentoo.org/show_bug.cgi?id=227333
- export CFLAGS="$CFLAGS -D_GNU_SOURCE"
-
- # Adjusting PATHs in manpages
- for i in bin/named/named.8 bin/check/named-checkconf.8 bin/rndc/rndc.8; do
- sed -i \
- -e 's:/etc/named.conf:/etc/bind/named.conf:g' \
- -e 's:/etc/rndc.conf:/etc/bind/rndc.conf:g' \
- -e 's:/etc/rndc.key:/etc/bind/rndc.key:g' \
- "${i}" || return 1
- done
-
- patch -p0 -i "$srcdir"/bind.so_bsdcompat.patch || return 1
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc/bind \
- --localstatedir=/var \
- --with-openssl=/usr \
- --disable-linux-caps \
- --without-libxml2 \
- --disable-threads \
- --enable-ipv6 \
- --enable-shared \
- --enable-static \
- --with-libtool \
- --with-randomdev=/dev/random \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
-
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- install -d -m0770 -g named -o root "$pkgdir"/var/bind \
- "$pkgdir"/var/bind/sec \
- "$pkgdir"/var/bind/dyn \
- "$pkgdir"/var/run/named \
- "$pkgdir"/var/log/named \
- || return 1
-
- install -d -m0750 -g named -o root "$pkgdir"/etc/bind \
- "$pkgdir"/var/bind/pri || return 1
-
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/*.la || return 1
-
- install -Dm755 "$srcdir"/$pkgname.initd \
- "$pkgdir"/etc/init.d/named || return 1
- install -Dm644 "$srcdir"/$pkgname.confd \
- "$pkgdir"/etc/conf.d/named || return 1
- install -Dm644 "$srcdir"/$pkgname.conf \
- "$pkgdir"/etc/bind/named.conf || return 1
- install -Dm644 "$srcdir"/$pkgname.named.ca \
- "$pkgdir"/var/bind/named.ca || return 1
- install -Dm644 "$srcdir"/$pkgname.127.zone \
- "$pkgdir"/var/bind/pri/127.zone || return 1
- install -Dm644 "$srcdir"/$pkgname.localhost.zone \
- "$pkgdir"/var/bind/pri/localhost.zone || return 1
- cd "$pkgdir"/var/bind
- ln -s named.ca root.cache || return 1
-}
-
-libs() {
- install=
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
-}
-
-tools() {
- install=
- depends=
- mkdir -p "$subpkgdir"/usr/bin
- for i in dig host nslookup nsupdate; do
- mv "$pkgdir"/usr/bin/${i} "$subpkgdir"/usr/bin/ || return 1
- done
-}
-
-md5sums="9281d0b04f711d28153ba1ab04a54026 bind-9.9.0.tar.gz
-f270a5b0a28ab6e818840c5c368ddbcc bind.so_bsdcompat.patch
-da52267d5d56317d08c0fb170fc14da8 bind.initd
-418a367cecfdf8760c92235d3967867e bind.confd
-be5fd752bdbd59385f2a559d603098d5 bind.conf
-a7455b009b7fccd74ac6f6eaa6902a00 bind.127.zone
-c3220168fabfb31a25e8c3a545545e34 bind.localhost.zone
-a94e29ac677846f3d4d618c50b7d34f1 bind.named.ca"
diff --git a/testing/bind/bind.127.zone b/testing/bind/bind.127.zone
deleted file mode 100644
index 2ad28de52c..0000000000
--- a/testing/bind/bind.127.zone
+++ /dev/null
@@ -1,11 +0,0 @@
-$ORIGIN 127.in-addr.arpa.
-$TTL 1W
-@ 1D IN SOA localhost. root.localhost. (
- 2002081601 ; serial
- 3H ; refresh
- 15M ; retry
- 1W ; expiry
- 1D ) ; minimum
-
- 1D IN NS localhost.
-1 1D IN PTR localhost.
diff --git a/testing/bind/bind.conf b/testing/bind/bind.conf
deleted file mode 100644
index d58c61bde0..0000000000
--- a/testing/bind/bind.conf
+++ /dev/null
@@ -1,53 +0,0 @@
-options {
- directory "/var/bind";
-
- // uncomment the following lines to turn on DNS forwarding,
- // and change the forwarding ip address(es) :
- //forward first;
- //forwarders {
- // 123.123.123.123;
- // 123.123.123.123;
- //};
-
- listen-on-v6 { none; };
- listen-on { 127.0.0.1; };
-
- // to allow only specific hosts to use the DNS server:
- //allow-query {
- // 127.0.0.1;
- //};
-
- // if you have problems and are behind a firewall:
- //query-source address * port 53;
- pid-file "/var/run/named/named.pid";
-};
-
-// Briefly, a zone which has been declared delegation-only will be effectively
-// limited to containing NS RRs for subdomains, but no actual data beyond its
-// own apex (for example, its SOA RR and apex NS RRset). This can be used to
-// filter out "wildcard" or "synthesized" data from NAT boxes or from
-// authoritative name servers whose undelegated (in-zone) data is of no
-// interest.
-// See http://www.isc.org/products/BIND/delegation-only.html for more info
-
-//zone "COM" { type delegation-only; };
-//zone "NET" { type delegation-only; };
-
-zone "." IN {
- type hint;
- file "named.ca";
-};
-
-zone "localhost" IN {
- type master;
- file "pri/localhost.zone";
- allow-update { none; };
- notify no;
-};
-
-zone "127.in-addr.arpa" IN {
- type master;
- file "pri/127.zone";
- allow-update { none; };
- notify no;
-};
diff --git a/testing/bind/bind.confd b/testing/bind/bind.confd
deleted file mode 100644
index a9af5676f7..0000000000
--- a/testing/bind/bind.confd
+++ /dev/null
@@ -1,8 +0,0 @@
-# Set various named options here.
-OPTS=""
-
-# Set this to the number of processors you have.
-# CPU="1"
-
-# Scheduling priority: 19 is the lowest and -20 is the highest.
-# NICELEVEL="0"
diff --git a/testing/bind/bind.initd b/testing/bind/bind.initd
deleted file mode 100644
index fa9ffb3434..0000000000
--- a/testing/bind/bind.initd
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/sbin/runscript
-
-extra_commands="checkconfig checkzones"
-extra_started_commands="reload"
-
-depend() {
- need net
- use logger
- provide dns
-}
-
-: ${NAMED_CONF:=/etc/bind/named.conf}
-
-depend() {
- need net
- after firewall
- use logger
- provide dns
-}
-
-_get_pidfile() {
- [ -n "${PIDFILE}" ] || PIDFILE=$(\
- /usr/sbin/named-checkconf -p ${NAMED_CONF} | grep 'pid-file' | cut -d\" -f2)
- [ -z "${PIDFILE}" ] && PIDFILE=/var/run/named/named.pid
-}
-
-checkconfig() {
- ebegin "Checking named configuration"
-
- if [ ! -f "${NAMED_CONF}" ] ; then
- eerror "No ${NAMED_CONF} file exists!"
- return 1
- fi
-
- /usr/sbin/named-checkconf ${NAMED_CONF} || {
- eerror "named-checkconf failed! Please fix your config first."
- return 1
- }
- eend 0
- return 0
-}
-
-checkzones() {
- ebegin "Checking named configuration and zones"
- /usr/sbin/named-checkconf -z -j ${NAMED_CONF}
- eend $?
-}
-
-start() {
- local piddir
- ebegin "Starting named"
- _get_pidfile
- piddir="${PIDFILE%/*}"
- if [ ! -d "${piddir}" ]; then
- checkpath -q -d -o root:named -m 0770 "${piddir}" || {
- eend 1
- return 1
- }
- fi
-
- checkconfig || { eend 1; return 1; }
-
- # create piddir (usually /var/run/named) if necessary, bug 334535
- _get_pidfile
- piddir="${PIDFILE%/*}"
- if [ ! -d "${piddir}" ]; then
- checkpath -q -d -o root:named -m 0770 "${piddir}" || {
- eend 1
- return 1
- }
- fi
-
- # In case someone have $CPU set in /etc/conf.d/named
- if [ -n "${CPU}" ] && [ "${CPU}" -gt 0 ]; then
- CPU="-n ${CPU}"
- fi
-
- start-stop-daemon --start --pidfile ${PIDFILE} \
- --nicelevel ${NICELEVEL:-0} \
- --exec /usr/sbin/named \
- -- -u named ${CPU} ${OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping named"
- start-stop-daemon --stop --quiet --pidfile $PIDFILE
- eend $?
-}
-
diff --git a/testing/bind/bind.localhost.zone b/testing/bind/bind.localhost.zone
deleted file mode 100644
index 338d7050ca..0000000000
--- a/testing/bind/bind.localhost.zone
+++ /dev/null
@@ -1,11 +0,0 @@
-$TTL 1W
-@ IN SOA ns.localhost. root.localhost. (
- 2002081601 ; Serial
- 28800 ; Refresh
- 14400 ; Retry
- 604800 ; Expire - 1 week
- 86400 ) ; Minimum
-@ IN NS ns
-ns IN A 127.0.0.1
-
-ns IN AAAA ::1
diff --git a/testing/bind/bind.named.ca b/testing/bind/bind.named.ca
deleted file mode 100644
index 902a7047f9..0000000000
--- a/testing/bind/bind.named.ca
+++ /dev/null
@@ -1,85 +0,0 @@
-; This file holds the information on root name servers needed to
-; initialize cache of Internet domain name servers
-; (e.g. reference this file in the "cache . <file>"
-; configuration file of BIND domain name servers).
-;
-; This file is made available by InterNIC
-; under anonymous FTP as
-; file /domain/named.root
-; on server FTP.INTERNIC.NET
-; -OR- RS.INTERNIC.NET
-;
-; last update: Feb 04, 2008
-; related version of root zone: 2008020400
-;
-; formerly NS.INTERNIC.NET
-;
-. 3600000 IN NS A.ROOT-SERVERS.NET.
-A.ROOT-SERVERS.NET. 3600000 A 198.41.0.4
-A.ROOT-SERVERS.NET. 3600000 AAAA 2001:503:BA3E::2:30
-;
-; formerly NS1.ISI.EDU
-;
-. 3600000 NS B.ROOT-SERVERS.NET.
-B.ROOT-SERVERS.NET. 3600000 A 192.228.79.201
-;
-; formerly C.PSI.NET
-;
-. 3600000 NS C.ROOT-SERVERS.NET.
-C.ROOT-SERVERS.NET. 3600000 A 192.33.4.12
-;
-; formerly TERP.UMD.EDU
-;
-. 3600000 NS D.ROOT-SERVERS.NET.
-D.ROOT-SERVERS.NET. 3600000 A 128.8.10.90
-;
-; formerly NS.NASA.GOV
-;
-. 3600000 NS E.ROOT-SERVERS.NET.
-E.ROOT-SERVERS.NET. 3600000 A 192.203.230.10
-;
-; formerly NS.ISC.ORG
-;
-. 3600000 NS F.ROOT-SERVERS.NET.
-F.ROOT-SERVERS.NET. 3600000 A 192.5.5.241
-F.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:2f::f
-;
-; formerly NS.NIC.DDN.MIL
-;
-. 3600000 NS G.ROOT-SERVERS.NET.
-G.ROOT-SERVERS.NET. 3600000 A 192.112.36.4
-;
-; formerly AOS.ARL.ARMY.MIL
-;
-. 3600000 NS H.ROOT-SERVERS.NET.
-H.ROOT-SERVERS.NET. 3600000 A 128.63.2.53
-H.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:1::803f:235
-;
-; formerly NIC.NORDU.NET
-;
-. 3600000 NS I.ROOT-SERVERS.NET.
-I.ROOT-SERVERS.NET. 3600000 A 192.36.148.17
-;
-; operated by VeriSign, Inc.
-;
-. 3600000 NS J.ROOT-SERVERS.NET.
-J.ROOT-SERVERS.NET. 3600000 A 192.58.128.30
-J.ROOT-SERVERS.NET. 3600000 AAAA 2001:503:C27::2:30
-;
-; operated by RIPE NCC
-;
-. 3600000 NS K.ROOT-SERVERS.NET.
-K.ROOT-SERVERS.NET. 3600000 A 193.0.14.129
-K.ROOT-SERVERS.NET. 3600000 AAAA 2001:7fd::1
-;
-; operated by ICANN
-;
-. 3600000 NS L.ROOT-SERVERS.NET.
-L.ROOT-SERVERS.NET. 3600000 A 199.7.83.42
-;
-; operated by WIDE
-;
-. 3600000 NS M.ROOT-SERVERS.NET.
-M.ROOT-SERVERS.NET. 3600000 A 202.12.27.33
-M.ROOT-SERVERS.NET. 3600000 AAAA 2001:dc3::35
-; End of File
diff --git a/testing/bind/bind.pre-install b/testing/bind/bind.pre-install
deleted file mode 100644
index e0a615ef08..0000000000
--- a/testing/bind/bind.pre-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-addgroup -S named 2>/dev/null
-adduser -h /etc/bind -s /bin/false -G named -D named 2>/dev/null
-exit 0
-
diff --git a/testing/bind/bind.so_bsdcompat.patch b/testing/bind/bind.so_bsdcompat.patch
deleted file mode 100644
index 83120f77de..0000000000
--- a/testing/bind/bind.so_bsdcompat.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/isc/unix/socket.c.orig 2005-11-03 17:08:42.000000000 -0600
-+++ lib/isc/unix/socket.c 2006-02-18 13:09:15.000000000 -0600
-@@ -245,6 +245,8 @@
-
- #define SOCK_DEAD(s) ((s)->references == 0)
-
-+#undef SO_BSDCOMPAT
-+
- static void
- manager_log(isc_socketmgr_t *sockmgr,
- isc_logcategory_t *category, isc_logmodule_t *module, int level,