aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/alpine-baselayout/APKBUILD1
-rw-r--r--testing/xf86-video-openchrome/APKBUILD48
-rw-r--r--testing/xf86-video-openchrome/openchrome.xinf39
3 files changed, 88 insertions, 0 deletions
diff --git a/main/alpine-baselayout/APKBUILD b/main/alpine-baselayout/APKBUILD
index cfba77bb79..047d40452e 100644
--- a/main/alpine-baselayout/APKBUILD
+++ b/main/alpine-baselayout/APKBUILD
@@ -5,6 +5,7 @@ pkgrel=3
pkgdesc="Alpine base dir structure and init scripts"
url=http://git.alpinelinux.org/cgit/alpine-baselayout
depends=
+options="!fhs"
install="$pkgname.pre-upgrade"
source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2
0001-blacklist-viafb-and-e_powersaver.patch
diff --git a/testing/xf86-video-openchrome/APKBUILD b/testing/xf86-video-openchrome/APKBUILD
new file mode 100644
index 0000000000..b8419ec337
--- /dev/null
+++ b/testing/xf86-video-openchrome/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-openchrome
+pkgver=0.3.0_pre20120227
+pkgrel=0
+pkgdesc="X.Org driver for VIA/S3G cards"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+subpackages="$pkgname-doc"
+depends=
+makedepends="pkgconfig xorg-server-dev libxi-dev libxvmc-dev fontsproto glproto
+ randrproto videoproto renderproto xf86driproto mesa-dev util-macros
+ autoconf automake libtool
+ "
+
+source="http://www.infradead.org/~jsimmons/release_0_3_0-Feb27.tar.bz2
+ openchrome.xinf
+ "
+
+_builddir="$srcdir"/xf86-video-openchrome-kms_branch
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ ./autogen.sh
+}
+
+build() {
+ cd "$_builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" -name '*.la' -delete
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ install -Dm644 "$srcdir"/openchrome.xinf \
+ "$pkgdir"/usr/share/hwdata/videoaliases/openchrome.xinf
+}
+
+md5sums="b8ca0911d178775fa55c4dd351052f3a release_0_3_0-Feb27.tar.bz2
+d6906087f0e93ea2d98e553f4dfbcc97 openchrome.xinf"
diff --git a/testing/xf86-video-openchrome/openchrome.xinf b/testing/xf86-video-openchrome/openchrome.xinf
new file mode 100644
index 0000000000..7b15c911a9
--- /dev/null
+++ b/testing/xf86-video-openchrome/openchrome.xinf
@@ -0,0 +1,39 @@
+# NOTE: Comments in openchrome 0.2.1 driver source indicate this device does not
+# exist in the wild, so it has been disabled for now.
+#alias pcivideo:v00001106d00003022sv*sd*bc*sc*i* openchrome
+
+# 1106:3108 - K8M800 (PCI_CHIP_VT3204)
+alias pcivideo:v00001106d00003108sv*sd*bc*sc*i* openchrome
+
+# 1106:3118 - PM800/PM880/CN400 (PCI_CHIP_VT3259)
+alias pcivideo:v00001106d00003118sv*sd*bc*sc*i* openchrome
+
+# 1106:3122 - CLE266 (PCI_CHIP_CLE3122)
+alias pcivideo:v00001106d00003122sv*sd*bc*sc*i* openchrome
+
+# 1106:7205 - KM400/KN400 (PCI_CHIP_VT3205)
+alias pcivideo:v00001106d00007205sv*sd*bc*sc*i* openchrome
+
+# 1106:3344 - VM800 (PCI_CHIP_VT3314)
+alias pcivideo:v00001106d00003344sv*sd*bc*sc*i* openchrome
+
+# 1106:3157 - CX700 (PCI_CHIP_VT3324)
+alias pcivideo:v00001106d00003157sv*sd*bc*sc*i* openchrome
+
+# 1106:3343 - P4M890 (PCI_CHIP_VT3327)
+alias pcivideo:v00001106d00003343sv*sd*bc*sc*i* openchrome
+
+# 1106:3230 - K8M890 (PCI_CHIP_VT3336)
+alias pcivideo:v00001106d00003230sv*sd*bc*sc*i* openchrome
+
+# 1106:3371 - P4M900 (PCI_CHIP_VT3364)
+alias pcivideo:v00001106d00003371sv*sd*bc*sc*i* openchrome
+
+# 1106:1122 - VX800 (PCI_CHIP_VT3353)
+alias pcivideo:v00001106d00001122sv*sd*bc*sc*i* openchrome
+
+# 1106:5122 - VX855 (PCI_CHIP_VT3409)
+alias pcivideo:v00001106d00005122sv*sd*bc*sc*i* openchrome
+
+# 1106:7122 - VX855 (PCI_CHIP_VT3410)
+alias pcivideo:v00001106d00007122sv*sd*bc*sc*i* openchrome