aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-sendfile/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sendfile/APKBUILD b/testing/py-sendfile/APKBUILD
new file mode 100644
index 0000000000..ca28e45dda
--- /dev/null
+++ b/testing/py-sendfile/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sendfile
+_pkgname=pysendfile
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="A Python interface to sendfile"
+url="https://pypi.python.org/pypi/pysendfile"
+arch="all"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e7b301eddd703ab74a48c59a8fda1f97 pysendfile-2.0.1.tar.gz"
+sha256sums="510a414b270986fba3c79cb76d90a4c910c701bfb43ff983a5d4e92846050e17 pysendfile-2.0.1.tar.gz"
+sha512sums="d6ee08eb251fac30c90a9ee829fd992f3620697eef2893ced5a2c6273486c3c5fd35c70962585a8d747d578817391f91c929bfeeba8c4485d52a15748229ca9c pysendfile-2.0.1.tar.gz"