aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-pip/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-pip/APKBUILD b/testing/py-pip/APKBUILD
new file mode 100644
index 0000000000..18386c58fb
--- /dev/null
+++ b/testing/py-pip/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pip
+_pkgname=pip
+pkgver=1.0
+pkgrel=0
+pkgdesc="A tool for installing and managing Python packages"
+url="http://www.pip-installer.org"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="327fc4a03df189506966e15021730550 pip-1.0.tar.gz"