aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/nghttp2/APKBUILD28
1 files changed, 8 insertions, 20 deletions
diff --git a/testing/nghttp2/APKBUILD b/testing/nghttp2/APKBUILD
index 72755e7b2d..b7fc714f4f 100644
--- a/testing/nghttp2/APKBUILD
+++ b/testing/nghttp2/APKBUILD
@@ -1,32 +1,21 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nghttp2
-pkgver=1.12.0
+pkgver=1.13.0
pkgrel=0
pkgdesc="Experimental HTTP/2 client, server and proxy"
url="https://nghttp2.org/"
arch="all"
license="MIT"
depends=""
-depends_dev=""
-makedepends="$depends_dev python-dev libev-dev openssl-dev zlib-dev"
+makedepends="python2-dev libev-dev openssl-dev zlib-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,7 +24,6 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --disable-ptyhon-bindings \
--disable-static \
--without-libxml2 \
--without-spdylay \
@@ -44,10 +32,10 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="1cea28d8c1c1b7de81444658ae327600 nghttp2-1.12.0.tar.xz"
-sha256sums="445c24243b8132b031c2c9fc9fe99f5abadbce2db4fbdf7eb6d3beaa5797dd4b nghttp2-1.12.0.tar.xz"
-sha512sums="7feeb87e55d94558a6d42306fe38ba6ea702242733347db18023deddd7e0a956995ed6df0595d5c40508394011f2188cd71c5e7cbcddb8fb58222a27b1c27c6b nghttp2-1.12.0.tar.xz"
+md5sums="908f5f1b86a1ba8b142ece7129c8a954 nghttp2-1.13.0.tar.xz"
+sha256sums="9d0ef97715049cd935fa0d965e6c807249549469aa95eb4dc67c69c2557d5bb2 nghttp2-1.13.0.tar.xz"
+sha512sums="d6dba96c242f0b06e54f38debecff810bdc736fb7a9586598017527818ece407990c85d42d0867e582d9d1cd16daace1bbfe3612fda4babc8785b1cd7abc0ec2 nghttp2-1.13.0.tar.xz"