aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/patchwork/APKBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/testing/patchwork/APKBUILD b/testing/patchwork/APKBUILD
index 8e1b695068..8d7ca43fbb 100644
--- a/testing/patchwork/APKBUILD
+++ b/testing/patchwork/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=0_git20150420
-pkgrel=3
+pkgrel=4
pkgdesc="Web-based patch tracking system "
url="http://jk.ozlabs.org/projects/patchwork/"
arch="noarch"
@@ -19,6 +19,16 @@ giturl="git://ozlabs.org/home/jk/git/patchwork"
disturl="dev.alpinelinux.org:/archive/$pkgname/"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
return 0