aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/lua-resty-http/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/lua-resty-http/APKBUILD b/community/lua-resty-http/APKBUILD
index 9763d297fd..ef6c687825 100644
--- a/community/lua-resty-http/APKBUILD
+++ b/community/lua-resty-http/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=lua-resty-http
pkgver=0.10
-pkgrel=0
+pkgrel=1
pkgdesc="Lua HTTP client cosocket driver for OpenResty / ngx_lua"
url="https://github.com/pintsized/lua-resty-http"
arch="noarch"
@@ -26,9 +26,13 @@ _subpackage() {
pkgdesc="$pkgdesc (Lua $lver)"
depends="lua$lver"
install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
+ local rockdir="$subpkgdir/usr/lib/luarocks/rocks-$lver/$pkgname/$pkgver-1"
cd "$builddir"
make install DESTDIR="$subpkgdir" LUA_LIB_DIR="/usr/share/lua/$lver"
+
+ mkdir -p "$rockdir"
+ echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
sha512sums="5ce79bd5e58c09418470fd588670b79610085b61571861c6c9fd71e716c6b599a426e4045431c0e8ab493b5b66d2f851251fc2b0aaed338433619ff3669aab05 lua-resty-http-0.10.tar.gz"