aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/perl-file-which/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/perl-file-which/APKBUILD b/main/perl-file-which/APKBUILD
index b3167f970c..c63ca5caf8 100644
--- a/main/perl-file-which/APKBUILD
+++ b/main/perl-file-which/APKBUILD
@@ -3,28 +3,30 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=perl-file-which
_pkgreal=File-Which
-pkgver=1.09
+pkgver=1.18
pkgrel=0
-pkgdesc="Portable implementation of the "which" utility"
+pkgdesc="Perl implementation of the which utility as an API"
url="http://search.cpan.org/dist/File-Which/"
arch="noarch"
license="GPL PerlArtistic"
-cpandepends="perl-test-script"
-cpanmakedepends=""
+cpandepends=""
+cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/P/PL/PLICEASE/$_pkgreal-$pkgver.tar.gz"
_builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
make && make test
}
@@ -34,4 +36,6 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="b9429edaad7f45caafa4d458afcfd8af File-Which-1.09.tar.gz"
+md5sums="554bfb36568d828fbeee64f4b9a9faa8 File-Which-1.18.tar.gz"
+sha256sums="964918a867bef2ce8b63786e24e947b249d4c0626d2d98b7c9a2155328f1391c File-Which-1.18.tar.gz"
+sha512sums="828942a034b9fbb6d2c6e00b47590084de0407d03a8cb9614e05d1a5a9692b0f7873052fcb136b80c2a9f0811e4c7a96a409efcb5745b10bf3fa8cf11048b4d2 File-Which-1.18.tar.gz"