aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/httpie/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/httpie/APKBUILD b/testing/httpie/APKBUILD
new file mode 100644
index 0000000000..774b83795e
--- /dev/null
+++ b/testing/httpie/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Isaksen <d@duniel.no>
+pkgname=httpie
+pkgver=0.9.8
+pkgrel=0
+pkgdesc="HTTPie is a command line HTTP client with an intuitive UI, JSON support, syntax highlighting and more"
+url="https://httpie.org/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py3-requests py3-pygments"
+makedepends=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/jakubroztocil/$pkgname/archive/0.9.8.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="dbf0bc1688f6fce99c245375b2059ab44c9d1b3dddd2144fab264545545d34b38d572017f468896d6e8cd8eeb94798ed625a085449b0fe0ddbb8b775c119413c httpie-0.9.8.tar.gz"