aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/virtualbox-guest-modules-hardened/APKBUILD (renamed from community/virtualbox-guest-modules-grsec/APKBUILD)27
-rw-r--r--community/virtualbox-guest-modules-hardened/const-struct-kernel_param.patch (renamed from community/virtualbox-guest-modules-grsec/const-struct-kernel_param.patch)0
-rw-r--r--community/virtualbox-guest-modules-hardened/vboxguest-log-use-c99.patch (renamed from community/virtualbox-guest-modules-grsec/vboxguest-log-use-c99.patch)0
3 files changed, 14 insertions, 13 deletions
diff --git a/community/virtualbox-guest-modules-grsec/APKBUILD b/community/virtualbox-guest-modules-hardened/APKBUILD
index c442178a39..2b01cfc48b 100644
--- a/community/virtualbox-guest-modules-grsec/APKBUILD
+++ b/community/virtualbox-guest-modules-hardened/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Ben Allen <bensallen@me.com>
# Contributor: Ben Allen <bensallen@me.com>
-_flavor=${FLAVOR:-grsec}
+_flavor=${FLAVOR:-hardened}
_kpkg=linux-$_flavor
_kver=4.9.24
-_kpkgrel=0
+_kpkgrel=1
# when chaning _ver we *must* bump _mypkgrel
_ver=5.1.14
@@ -13,7 +13,7 @@ _name=virtualbox-guest-modules
_kpkgver="$_kver-r$_kpkgrel"
_abi_release=${_kver}-${_kpkgrel}-${_flavor}
-_abi_release_virtgrsec=${_kver}-${_kpkgrel}-virtgrsec
+_abi_release_virthardened=${_kver}-${_kpkgrel}-virthardened
pkgname=${_name}-${_flavor}
pkgver=$_kver
@@ -22,12 +22,13 @@ pkgdesc="VirtualBox Additions kernel modules for $_flavor "
arch='x86 x86_64'
url='http://virtualbox.org'
license="GPL custom"
-makedepends="linux-grsec-dev=$_kpkgver linux-virtgrsec-dev=$_kpkgver sed coreutils"
-subpackages="$_name-virtgrsec:_virtgrsec"
+makedepends="linux-hardened-dev=$_kpkgver linux-virthardened-dev=$_kpkgver sed coreutils"
+subpackages="$_name-virthardened:_virthardened"
source="http://download.virtualbox.org/virtualbox/$_ver/VirtualBox-$_ver.tar.bz2
vboxguest-log-use-c99.patch
const-struct-kernel_param.patch
"
+provides="${_name}-grsec=${pkgver}-r${pkgrel}"
builddir="$srcdir"/VirtualBox-$_ver
prepare() {
@@ -53,7 +54,7 @@ prepare() {
"$builddir"/src/VBox/Additions/linux/export_modules \
"$srcdir/vbox-kmod-$_ver.tar.gz" || return 1
- for i in $_abi_release $_abi_release_virtgrsec; do
+ for i in $_abi_release $_abi_release_virthardened; do
mkdir -p "$srcdir/$i"
tar -C "$srcdir/$i" -zxf "$srcdir"/vbox-kmod-$_ver.tar.gz
done
@@ -61,7 +62,7 @@ prepare() {
build() {
local i
- for i in $_abi_release $_abi_release_virtgrsec; do
+ for i in $_abi_release $_abi_release_virthardened; do
cd "$srcdir/$i"
# Build Kernel Modules
make KERN_DIR=/lib/modules/${i}/build \
@@ -71,7 +72,7 @@ build() {
package() {
local i module=
- for i in $_abi_release $_abi_release_virtgrsec; do
+ for i in $_abi_release $_abi_release_virthardened; do
cd "$srcdir/$i"
for module in *.ko; do
install -v -D -m644 ${module} \
@@ -80,12 +81,12 @@ package() {
done
}
-_virtgrsec() {
- pkgdesc="VirtualBox Additions kernel modules for virtgrsec"
+_virthardened() {
+ pkgdesc="VirtualBox Additions kernel modules for virthardened"
mkdir -p "$subpkgdir"/lib/modules/
- # vboxvideo.ko won't load with virtgrsec kernel as it doesn't have DRM
- rm "$pkgdir"/lib/modules/$_abi_release_virtgrsec/misc/vboxvideo.ko
- mv "$pkgdir"/lib/modules/$_abi_release_virtgrsec \
+ # vboxvideo.ko won't load with virthardened kernel as it doesn't have DRM
+ rm "$pkgdir"/lib/modules/$_abi_release_virthardened/misc/vboxvideo.ko
+ mv "$pkgdir"/lib/modules/$_abi_release_virthardened \
"$subpkgdir"/lib/modules/
}
diff --git a/community/virtualbox-guest-modules-grsec/const-struct-kernel_param.patch b/community/virtualbox-guest-modules-hardened/const-struct-kernel_param.patch
index d73ae16133..d73ae16133 100644
--- a/community/virtualbox-guest-modules-grsec/const-struct-kernel_param.patch
+++ b/community/virtualbox-guest-modules-hardened/const-struct-kernel_param.patch
diff --git a/community/virtualbox-guest-modules-grsec/vboxguest-log-use-c99.patch b/community/virtualbox-guest-modules-hardened/vboxguest-log-use-c99.patch
index d8af408b8a..d8af408b8a 100644
--- a/community/virtualbox-guest-modules-grsec/vboxguest-log-use-c99.patch
+++ b/community/virtualbox-guest-modules-hardened/vboxguest-log-use-c99.patch