aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libgphoto2/APKBUILD22
-rw-r--r--main/libgphoto2/libjpeg_turbo_1.5.0_fix.patch72
2 files changed, 83 insertions, 11 deletions
diff --git a/main/libgphoto2/APKBUILD b/main/libgphoto2/APKBUILD
index 3c1b69e4d3..c4c220cc92 100644
--- a/main/libgphoto2/APKBUILD
+++ b/main/libgphoto2/APKBUILD
@@ -12,17 +12,14 @@ makedepends="$depends_dev libjpeg-turbo-dev libtool"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-doc"
replaces="libgphoto2-dev"
-source="http://downloads.sourceforge.net/gphoto/libgphoto2-$pkgver.tar.bz2"
+source="http://downloads.sourceforge.net/gphoto/libgphoto2-$pkgver.tar.bz2
+ libjpeg_turbo_1.5.0_fix.patch"
options="libtool"
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
udevscriptdir=/lib/udev ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,7 +32,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/lib/libgphoto2/*/*.a \
"$pkgdir"/usr/lib/*.a
@@ -46,6 +43,9 @@ package() {
"$pkgdir/usr/lib/libgphoto2/print-camera-list" udev-rules version 136 group camera mode 0660 > "$pkgdir/lib/udev/rules.d/54-gphoto.rules" || return 1
}
-md5sums="f1e53e684a3ea51cc7958d7e4eee7f37 libgphoto2-2.5.10.tar.bz2"
-sha256sums="8d8668d432ba595c7466442aec2cf553bdf8782ec171291dbc65717c633a4ef2 libgphoto2-2.5.10.tar.bz2"
-sha512sums="13f593e09e8428bf72fc783b4ddfd5fc418fcf42ebe17d05b44255458dbac956293fb189c48b609fba5586f39771d148a3541fa484ac51fd68c921f2f05ca18a libgphoto2-2.5.10.tar.bz2"
+md5sums="f1e53e684a3ea51cc7958d7e4eee7f37 libgphoto2-2.5.10.tar.bz2
+af8318eb34e73b30ccdb4f7357ce7a63 libjpeg_turbo_1.5.0_fix.patch"
+sha256sums="8d8668d432ba595c7466442aec2cf553bdf8782ec171291dbc65717c633a4ef2 libgphoto2-2.5.10.tar.bz2
+36723efa91099b14d3eff83acc90071d3453317dc1dd6fa114bfb76826f49184 libjpeg_turbo_1.5.0_fix.patch"
+sha512sums="13f593e09e8428bf72fc783b4ddfd5fc418fcf42ebe17d05b44255458dbac956293fb189c48b609fba5586f39771d148a3541fa484ac51fd68c921f2f05ca18a libgphoto2-2.5.10.tar.bz2
+b775bd47b5eef4171f4d030d9f55c0e9e1ac4c81678195f04d0af7fc1fb4780ed271ac8a22b73384aacfa6e2f81b795c4a0d37bceb993648bd34877404af6554 libjpeg_turbo_1.5.0_fix.patch"
diff --git a/main/libgphoto2/libjpeg_turbo_1.5.0_fix.patch b/main/libgphoto2/libjpeg_turbo_1.5.0_fix.patch
new file mode 100644
index 0000000000..b75e7dfada
--- /dev/null
+++ b/main/libgphoto2/libjpeg_turbo_1.5.0_fix.patch
@@ -0,0 +1,72 @@
+Description: Close bug #827629.
+ conflicting types for 'jpeg_mem_src' with
+ libjpeg-turbo62 1.5.0
+Author: Patrick Ohly <patrick.ohly@intel.com>
+Reviewed-by: Herbert Parentes Fortes Neto <hpfn@ig.com.br>
+Last-Update: 2016-06-19
+Index: libgphoto2-2.5.10/camlibs/ax203/jpeg_memsrcdest.c
+===================================================================
+--- libgphoto2-2.5.10.orig/camlibs/ax203/jpeg_memsrcdest.c
++++ libgphoto2-2.5.10/camlibs/ax203/jpeg_memsrcdest.c
+@@ -25,8 +25,8 @@
+ #include "jpeg_memsrcdest.h"
+
+ /* libjpeg8 and later come with their own (API compatible) memory source
+- and dest */
+-#if JPEG_LIB_VERSION < 80
++ and dest, and older versions may have it backported */
++#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
+
+ /* Expanded data source object for memory input */
+
+Index: libgphoto2-2.5.10/camlibs/ax203/jpeg_memsrcdest.h
+===================================================================
+--- libgphoto2-2.5.10.orig/camlibs/ax203/jpeg_memsrcdest.h
++++ libgphoto2-2.5.10/camlibs/ax203/jpeg_memsrcdest.h
+@@ -1,5 +1,7 @@
+ #include <jpeglib.h>
+
++#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
++
+ void
+ jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
+ unsigned long bufsize);
+@@ -7,3 +9,5 @@ jpeg_mem_src (j_decompress_ptr cinfo, un
+ void
+ jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
+ unsigned long * outsize);
++
++#endif
+Index: libgphoto2-2.5.10/camlibs/jl2005c/jpeg_memsrcdest.c
+===================================================================
+--- libgphoto2-2.5.10.orig/camlibs/jl2005c/jpeg_memsrcdest.c
++++ libgphoto2-2.5.10/camlibs/jl2005c/jpeg_memsrcdest.c
+@@ -25,8 +25,8 @@
+ #include "jpeg_memsrcdest.h"
+
+ /* libjpeg8 and later come with their own (API compatible) memory source
+- and dest */
+-#if JPEG_LIB_VERSION < 80
++ and dest, and older versions may have it backported */
++#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
+
+ /* Expanded data source object for memory input */
+
+Index: libgphoto2-2.5.10/camlibs/jl2005c/jpeg_memsrcdest.h
+===================================================================
+--- libgphoto2-2.5.10.orig/camlibs/jl2005c/jpeg_memsrcdest.h
++++ libgphoto2-2.5.10/camlibs/jl2005c/jpeg_memsrcdest.h
+@@ -1,5 +1,7 @@
+ #include <jpeglib.h>
+
++#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
++
+ void
+ jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
+ unsigned long bufsize);
+@@ -7,3 +9,5 @@ jpeg_mem_src (j_decompress_ptr cinfo, un
+ void
+ jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
+ unsigned long * outsize);
++
++#endif