aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/py-xml/APKBUILD31
-rw-r--r--main/py-xml/fix-python2.6.patch28
2 files changed, 0 insertions, 59 deletions
diff --git a/main/py-xml/APKBUILD b/main/py-xml/APKBUILD
deleted file mode 100644
index 33b1160e32..0000000000
--- a/main/py-xml/APKBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=py-xml
-pkgver=0.8.4
-pkgrel=2
-pkgdesc="Python XML parsing library."
-url="http://pyxml.sourceforge.net/"
-arch="all"
-license="custom"
-depends=
-makedepends="python2-dev"
-source="http://downloads.sourceforge.net/sourceforge/pyxml/PyXML-$pkgver.tar.gz
- fix-python2.6.patch"
-
-builddir="$srcdir"/PyXML-$pkgver
-build() {
- cd "$builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
- install -D -m644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" || return 1
-}
-
-md5sums="1f7655050cebbb664db976405fdba209 PyXML-0.8.4.tar.gz
-4b652e0c866e3cca7e2386e8e383d5ba fix-python2.6.patch"
-sha256sums="9fab66f9584fb8e67aebd8745a5c97bf1c5a2e2e461adf68862bcec64e448c13 PyXML-0.8.4.tar.gz
-163dd62e1b495c4918b568295e6da95c06ac6fb9982f28b80998b1f3fed97194 fix-python2.6.patch"
-sha512sums="68d9802a58b8ce90d668d2ba659136dc5377e224fdb837284fdcaf640f28b3bb400bf485d602689905d56121b9ffaa7f7758b4a2f262d1321c8b9890952c8a1e PyXML-0.8.4.tar.gz
-c943212f8c12cc9b1d500b30894d9f9b0b3acc883ffbc4c3d8db9da56fdabc22a8d653c2515ae453c90c53400e0b4dfaf0b24a1f5116453f567ea89f9d671706 fix-python2.6.patch"
diff --git a/main/py-xml/fix-python2.6.patch b/main/py-xml/fix-python2.6.patch
deleted file mode 100644
index 7bf1c46fc9..0000000000
--- a/main/py-xml/fix-python2.6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ur a/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py b/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py
---- a/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2003-03-11 15:01:34.000000000 +0100
-+++ b/xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2009-05-25 16:32:26.000000000 +0200
-@@ -24,8 +24,8 @@
- self._rel = rel
- nt = ParsedNodeTest.ParsedNodeTest('node', '')
- ppl = ParsedPredicateList.ParsedPredicateList([])
-- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-- self._step = ParsedStep.ParsedStep(as, nt, ppl)
-+ asp = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-+ self._step = ParsedStep.ParsedStep(asp, nt, ppl)
- return
-
- def evaluate(self, context):
-diff -ur a/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py b/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py
---- a/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2003-03-11 15:01:34.000000000 +0100
-+++ b/xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2009-05-25 16:27:55.000000000 +0200
-@@ -28,8 +28,8 @@
- self._right = right
- nt = ParsedNodeTest.ParsedNodeTest('node','')
- ppl = ParsedPredicateList.ParsedPredicateList([])
-- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-- self._middle = ParsedStep.ParsedStep(as, nt, ppl)
-+ asp = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
-+ self._middle = ParsedStep.ParsedStep(asp, nt, ppl)
-
- def evaluate(self, context):
- res = []