aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/wireguard-tools/APKBUILD4
-rw-r--r--community/wireguard-tools/alpine-compat.patch3
2 files changed, 4 insertions, 3 deletions
diff --git a/community/wireguard-tools/APKBUILD b/community/wireguard-tools/APKBUILD
index e1a549f643..a01aedab4b 100644
--- a/community/wireguard-tools/APKBUILD
+++ b/community/wireguard-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=wireguard-tools
pkgver=0.0.20190913
-pkgrel=0
+pkgrel=1
pkgdesc="Next generation secure network tunnel: userspace tools"
arch="all"
url="https://www.wireguard.com"
@@ -62,4 +62,4 @@ bashcomp() {
}
sha512sums="0d6e754df2f919c288ffe46131df29624e9958d39220369558089218c386450733f2baf97eb5d14154aa17a8d6b01bb0c34e3a1c4587830ed0d792d6ef06aa05 WireGuard-0.0.20190913.tar.xz
-4577574333f023217ae6e0945807e1ccd2dec7caa87e329b1d5b44569f6b5969663ad74f8154b85d3dc7063dd762649e3fa87c7667e238ffb77c0e5df9245a5e alpine-compat.patch"
+07218933ca0b6891d159498dc4e92e3e178a91018d78775118fcad97425a212b8b36b04cf7f29c48b624fb8bbd4bc0d18cdf98ac3f3caf0034342d2195f9f129 alpine-compat.patch"
diff --git a/community/wireguard-tools/alpine-compat.patch b/community/wireguard-tools/alpine-compat.patch
index 1268ffb6b9..27d9ba5a64 100644
--- a/community/wireguard-tools/alpine-compat.patch
+++ b/community/wireguard-tools/alpine-compat.patch
@@ -1,3 +1,4 @@
+
diff --git a/src/tools/wg-quick/linux.bash b/src/tools/wg-quick/linux.bash
--- a/src/tools/wg-quick/linux.bash
+++ b/src/tools/wg-quick/linux.bash
@@ -6,7 +7,7 @@ diff --git a/src/tools/wg-quick/linux.bash b/src/tools/wg-quick/linux.bash
while read -r key _ value; do
[[ $value -eq 1 ]] && sysctl -q "$key=2"
- done < <(sysctl -a -r '^net\.ipv4.conf\.[^ .=]+\.rp_filter$')
-+ done < <(sysctl -a 2>/dev/null | sed -n -r 's#^(net\.ipv4.conf\.[^ .=]+\.rp_filter).*$#\1#p')
++ done < <(sysctl -a 2>/dev/null | sed -n -r 's#^(net\.ipv4.conf\.[^ .=]+\.rp_filter)#\1#p')
return 0
}