aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/thermald/APKBUILD11
-rw-r--r--testing/thermald/no-werror.patch14
-rw-r--r--testing/thermald/ppc64le.patch36
3 files changed, 20 insertions, 41 deletions
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
index 5e20b93c54..09bc0a8947 100644
--- a/testing/thermald/APKBUILD
+++ b/testing/thermald/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer:
pkgname=thermald
_pkgname=thermal_daemon
-pkgver=1.6
-pkgrel=1
+pkgver=1.9
+pkgrel=0
pkgdesc="Thermal daemon for IA"
url="https://github.com/01org/thermal_daemon"
arch="all !armhf !armv7 !aarch64 !s390x"
@@ -12,7 +12,8 @@ makedepends="autoconf automake libtool dbus-glib-dev libxml2-dev linux-headers"
subpackages="$pkgname-doc $pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://github.com/01org/$_pkgname/archive/v$pkgver.tar.gz
thermald.initd
- ppc64le.patch"
+ no-werror.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
@@ -39,6 +40,6 @@ package() {
"$pkgdir"/etc/init.d/$pkgname
}
-sha512sums="ddcd01dcd2f6b5666ffa16ba635734e4c146244b5df7c3f0deb8120f8ee7ebf1f4ee302d49db2b7e9a4950045650922977bd40bf6b38ccea9896f81e06df1d49 thermald-1.6.tar.gz
+sha512sums="71fa6e9fc2f55623ed0acdb65f9699d5ea2c89c4092546a73d53ac3ea3ca0a5c60f3360c8bef0af9daeeecfe9a20411d9e4d25bc1d89349cfe83ebb03ba387a8 thermald-1.9.tar.gz
ea8964b15fdebc2fb59e93c15b813b93691c2ba01689ac6080f1308a3063b23cba56b4539ccae87575689036f74300a1c22c9b0e77d4ecef9bc08198d7fe4892 thermald.initd
-517d2c26dc5464c59e9c0cbea2bb1bcbe78cad87a26965cec8ec6d48a4b1bbb25c73bc5e772bbf0754e56222c8497d534b974b3a94c104bc4213be740aea9a5d ppc64le.patch"
+ea72002dcdfa907964f2ffc28947d8b2b536a93876d65872085aa9ebf2bdb549fae9c43412d74590ad88d2d71c48067726cc755630c41e30d77eb9c0c56d7308 no-werror.patch"
diff --git a/testing/thermald/no-werror.patch b/testing/thermald/no-werror.patch
new file mode 100644
index 0000000000..726ff58ba0
--- /dev/null
+++ b/testing/thermald/no-werror.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile.am b/Makefile.am
+index 836b8f0..e13dc32 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,8 +22,7 @@ AM_CXXFLAGS = ${DBUS_CFLAGS}\
+ -Wignored-qualifiers\
+ -Wmissing-field-initializers\
+ -Wtype-limits\
+- -Wuninitialized\
+- -Werror
++ -Wuninitialized
+
+ EXTRA_DIST=Makefile.glib \
+ thermald.pc.in
diff --git a/testing/thermald/ppc64le.patch b/testing/thermald/ppc64le.patch
deleted file mode 100644
index 76d5527b79..0000000000
--- a/testing/thermald/ppc64le.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Author: Breno Leitao <breno.leitao@gmail.com>
-Date: Sat Apr 8 21:31:07 2017 +0000
-
- Enable the build on ppc64le Currently musl on ppc64le does not define
- cpuid.h. Avoiding calling it.
-
- Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
-
---- a/src/thd_engine.cpp.old
-+++ b/src/thd_engine.cpp
-@@ -35,13 +35,15 @@
- #include <errno.h>
- #include <sys/types.h>
- #include <sys/utsname.h>
--#include <cpuid.h>
- #include <locale>
- #include "thd_engine.h"
- #include "thd_cdev_therm_sys_fs.h"
- #include "thd_zone_therm_sys_fs.h"
- #include "thd_zone_dynamic.h"
- #include "thd_cdev_gen_sysfs.h"
-+#ifndef __powerpc__
-+#include <cpuid.h>
-+#endif
-
- static void *cthd_engine_thread(void *arg);
-
-@@ -603,7 +605,7 @@
- };
-
- int cthd_engine::check_cpu_id() {
--#ifndef ANDROID
-+#if !defined(ANDROID) && !defined(__powerpc__)
- // Copied from turbostat program
- unsigned int ebx, ecx, edx, max_level;
- unsigned int fms, family, model, stepping;