aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/autoconf/APKBUILD14
-rw-r--r--main/autoconf/autoconf-2.69-fix-perl-regex.patch11
2 files changed, 22 insertions, 3 deletions
diff --git a/main/autoconf/APKBUILD b/main/autoconf/APKBUILD
index c1e78a21a1..a2736accf3 100644
--- a/main/autoconf/APKBUILD
+++ b/main/autoconf/APKBUILD
@@ -1,14 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=autoconf
pkgver=2.69
-pkgrel=0
+pkgrel=1
pkgdesc="A GNU tool for automatically configuring source code"
arch="noarch"
license="GPL-2.0-or-later"
url="https://www.gnu.org/software/autoconf"
depends="m4 perl"
subpackages="$pkgname-doc"
-source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ autoconf-2.69-fix-perl-regex.patch
+ "
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -25,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
@@ -33,4 +40,5 @@ package() {
rm -f "$pkgdir"/usr/share/info/standards.info
}
-sha512sums="e34c7818bcde14d2cb13cdd293ed17d70740d4d1fd7c67a07b415491ef85d42f450d4fe5f8f80cc330bf75c40a62774c51a4336e06e8da07a4cbc49922d975ee autoconf-2.69.tar.gz"
+sha512sums="e34c7818bcde14d2cb13cdd293ed17d70740d4d1fd7c67a07b415491ef85d42f450d4fe5f8f80cc330bf75c40a62774c51a4336e06e8da07a4cbc49922d975ee autoconf-2.69.tar.gz
+8b779ecec178091c899b75df4471fb72334a062d6b413502d414e8827fe0c9e2f335a8bef6878ae261e1af1568e3fe71fe82d6b5e53cb54e6585ffd91f069d8d autoconf-2.69-fix-perl-regex.patch"
diff --git a/main/autoconf/autoconf-2.69-fix-perl-regex.patch b/main/autoconf/autoconf-2.69-fix-perl-regex.patch
new file mode 100644
index 0000000000..9cccf912b0
--- /dev/null
+++ b/main/autoconf/autoconf-2.69-fix-perl-regex.patch
@@ -0,0 +1,11 @@
+--- autoconf-2.69/bin/autoscan.in.old 2012-04-25 02:37:26.000000000 +0000
++++ autoconf-2.69/bin/autoscan.in 2017-08-03 23:59:38.720214631 +0000
+@@ -358,7 +358,7 @@
+ {
+ # Strip out comments and variable references.
+ s/#.*//;
+- s/\${[^\}]*}//g;
++ s/\$\{[^\}]*\}//g;
+ s/@[^@]*@//g;
+
+ # Tokens in the code.