aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/mutagen/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/community/mutagen/APKBUILD b/community/mutagen/APKBUILD
index b0dedbc042..77bf2920ab 100644
--- a/community/mutagen/APKBUILD
+++ b/community/mutagen/APKBUILD
@@ -7,31 +7,26 @@ url="https://github.com/quodlibet/mutagen"
arch="noarch"
license="GPL-2.0-or-later"
depends="python3 py-mutagen"
-makedepends="python3-dev"
-checkdepends="py3-pytest py3-setuptools py3-hypothesis"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-flake8 py3-hypothesis"
subpackages="$pkgname-doc py-$pkgname:py"
-source="$pkgname-$pkgver.tar.gz::https://github.com/quodlibet/mutagen/archive/release-$pkgver.tar.gz"
-
-# we dont have all the needed deps for running the test suite yet
-options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/quodlibet/mutagen/archive/release-$pkgver.tar.gz
+ fix-pep8.patch::https://github.com/quodlibet/mutagen/commit/0ee86ef9d7e06639a388d0638732810b79998608.patch"
builddir="$srcdir/$pkgname-release-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
-package() {
- cd "$builddir"
- python3 setup.py install --root="$pkgdir"
-}
-
check() {
- cd "$builddir"
python3 setup.py test
}
+package() {
+ python3 setup.py install --root="$pkgdir"
+}
+
py() {
pkgdesc="Python library for mutagen"
depends="python3"
@@ -39,4 +34,5 @@ py() {
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-sha512sums="abb7fdb93f6f844c9b609f2544229e8d3d7a20a0158c494ca3c6393d9e26c73b32863f4b8bd5382e33493534e24a46770a7c187b7d453f526c15aeec0e851510 mutagen-1.42.0.tar.gz"
+sha512sums="abb7fdb93f6f844c9b609f2544229e8d3d7a20a0158c494ca3c6393d9e26c73b32863f4b8bd5382e33493534e24a46770a7c187b7d453f526c15aeec0e851510 mutagen-1.42.0.tar.gz
+29d5dccfed14f9db9bcd80a298f92b6831e5552edc4b106c20c4b0a4ad924983e36ccc866540cb49ba21340b0f29a4569a12ac0da6d3f5f263a91412641b6aeb fix-pep8.patch"