aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-pytest-xdist/APKBUILD45
1 files changed, 12 insertions, 33 deletions
diff --git a/community/py3-pytest-xdist/APKBUILD b/community/py3-pytest-xdist/APKBUILD
index 9bb11e0d3d..37728ac6e8 100644
--- a/community/py3-pytest-xdist/APKBUILD
+++ b/community/py3-pytest-xdist/APKBUILD
@@ -1,28 +1,26 @@
# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
-pkgname=pytest-xdist
-pkgver=1.28.0
+pkgname=py3-pytest-xdist
+pkgver=1.29.0
pkgrel=0
pkgdesc="pytest xdist plugin for distributed testing and loop-on-failing modes"
url="https://github.com/pytest-dev/pytest-xdist"
arch="noarch"
license="MIT"
-depends="py-execnet pytest pytest-forked py-six"
-checkdepends="py-filelock py-py"
-makedepends="py-setuptools py3-setuptools py-setuptools_scm"
-subpackages="py3-$pkgname:_py3 py2-$pkgname:_py2"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+depends="py3-execnet py3-pytest py3-pytest-forked py3-six"
+checkdepends="py3-filelock py3-py"
+makedepends="py3-setuptools py3-setuptools_scm"
+source="https://files.pythonhosted.org/packages/source/p/pytest-xdist/pytest-xdist-$pkgver.tar.gz"
+builddir="$srcdir/pytest-xdist-$pkgver"
+
+replaces="pytest-xdist" # Backwards compatibility
+provides="pytest-xdist=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- mkdir -p tmp_py2
- python2 setup.py install --root="$builddir/tmp_py2" --optimize=1
- PYTHONPATH="$builddir/tmp_py2/usr/lib/python2.7/site-packages:$PYTHONPATH" python2 -m pytest
-
mkdir -p tmp_py3
python3 setup.py install --root="$builddir/tmp_py3" --optimize=1
local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
@@ -30,26 +28,7 @@ check() {
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="89b8885103a944ae72535de40028db052f76631ade6f969489d3dc3a1a61a3233df6655d0905d9f5253f23740a15aea824b460c680e79c16f275b31cb2abd6ad pytest-xdist-1.28.0.tar.gz"
+sha512sums="b4d62d602cef103e69a42105c1455e52d67769b21c93f931831e577e7b5aa2e27d017a61634ebdde2be5a5db1a53453bb380d4b7d9e45f445320a9a2cb10a63c pytest-xdist-1.29.0.tar.gz"