aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/firefox/0002-Use-C99-math-isfinite.patch17
-rw-r--r--testing/firefox/APKBUILD64
-rw-r--r--testing/firefox/disable-moz-stackwalk.patch2
-rw-r--r--testing/firefox/fix-bug-1261392.patch27
-rw-r--r--testing/firefox/fix-fortify-inline.patch11
-rw-r--r--testing/firefox/fix-musl.patch11
-rw-r--r--testing/firefox/fix-rust-target.patch4
-rw-r--r--testing/firefox/fix-sandbox-membarrier.patch (renamed from testing/firefox/sandbox-membarrier.patch)2
-rw-r--r--testing/firefox/fix-seccomp-bpf.patch16
-rw-r--r--testing/firefox/fix-stack-overflow.patch45
-rw-r--r--testing/firefox/fix-toolkit.patch20
-rw-r--r--testing/firefox/fix-tools.patch2
-rw-r--r--testing/firefox/fix-webrtc-glibcisms.patch15
-rw-r--r--testing/firefox/mallinfo.patch4
-rw-r--r--testing/firefox/mozilla-build-arm.patch11
-rw-r--r--testing/firefox/rust-unitialized-field.patch19
16 files changed, 60 insertions, 210 deletions
diff --git a/testing/firefox/0002-Use-C99-math-isfinite.patch b/testing/firefox/0002-Use-C99-math-isfinite.patch
deleted file mode 100644
index ba4f5cfb3d..0000000000
--- a/testing/firefox/0002-Use-C99-math-isfinite.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./xpcom/ds/nsMathUtils.h.orig
-+++ ./xpcom/ds/nsMathUtils.h
-@@ -104,12 +104,12 @@
- #ifdef WIN32
- // NOTE: '!!' casts an int to bool without spamming MSVC warning C4800.
- return !!_finite(aNum);
--#elif defined(XP_DARWIN)
-+#elif defined(XP_DARWIN) || defined(_GLIBCXX_CMATH)
- // Darwin has deprecated |finite| and recommends |isfinite|. The former is
- // not present in the iOS SDK.
- return std::isfinite(aNum);
- #else
-- return finite(aNum);
-+ return isfinite(aNum);
- #endif
- }
-
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index e3876c6a1c..7dc153ee52 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -1,7 +1,7 @@
-# Contributor:
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=firefox
-pkgver=67.0.4
+pkgver=68.0
pkgrel=0
pkgdesc="Firefox web browser"
url="https://www.firefox.com/"
@@ -19,11 +19,10 @@ makedepends="
clang-dev
dbus-glib-dev
ffmpeg-dev
- gconf-dev
gtk+2.0-dev
gtk+3.0-dev
hunspell-dev
- icu-dev
+ icu-dev>=64.2
libevent-dev
libidl-dev
libjpeg-turbo-dev
@@ -34,14 +33,13 @@ makedepends="
libvorbis-dev
libxt-dev
libxcomposite-dev
- llvm8
+ llvm8-dev
mesa-dev
nasm
nodejs
nspr-dev
- nss-dev>=3.26
+ nss-dev>=3.44.1
nss-static
- paxmark
python3-dev
sqlite-dev
sed
@@ -55,18 +53,16 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkg
stab.h
fix-fortify-system-wrappers.patch
- fix-fortify-inline.patch
fix-seccomp-bpf.patch
fix-toolkit.patch
fix-tools.patch
mallinfo.patch
- mozilla-build-arm.patch
disable-moz-stackwalk.patch
+ fix-musl.patch
fix-rust-target.patch
- fix-bug-1261392.patch
fix-webrtc-glibcisms.patch
- sandbox-membarrier.patch
+ fix-sandbox-membarrier.patch
firefox.desktop
firefox-safe.desktop"
@@ -86,8 +82,6 @@ build() {
mkdir -p "$builddir"/objdir
cd "$builddir"/objdir
- sed -e 's/checkImpl/checkFFImpl/g' -i ../js/src/vm/JSContext*.h
-
export SHELL=/bin/sh
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
@@ -121,6 +115,7 @@ build() {
--enable-system-sqlite \
--enable-ffmpeg \
--enable-hardening \
+ --enable-rust-simd \
\
--with-system-bz2 \
--with-system-icu \
@@ -135,19 +130,11 @@ build() {
# FIXME: fix build with --with-system-libvpx and libvpx 1.8.0
# https://bugzilla.mozilla.org/show_bug.cgi?id=1525393
make
-
- # paxmark outside fakeroot
- paxmark -msp dist/bin/xpcshell
-
}
package() {
cd "$builddir"/objdir
- # only used for startupcache creation.
- local paxflags="-msp"
- paxmark "$paxflags" dist/bin/xpcshell
-
make install \
DESTDIR="$pkgdir" \
MOZ_MAKE_FLAGS="$MAKEOPTS"
@@ -167,17 +154,6 @@ package() {
install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/firefox.desktop
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
- # firefox currently does not work with mprotect. disable it for now
- local paxflags="-mp"
- [ "$CARCH" = "x86" ] && paxflags="-msp"
-
- paxmark "$paxflags" "$pkgdir"/$_mozappdir/firefox
- paxmark "$paxflags" "$pkgdir"/$_mozappdir/plugin-container
-
- # xulrunner stub launcher has changed to using a symlink overlay...
- # go figure
- ln -sf /usr/lib/xulrunner-${_xulver} ${pkgdir}/$_mozappdir/xulrunner
-
# launcher as symlink is broken from firefox-7.0
rm "$pkgdir"/usr/bin/firefox
libgl=$(scanelf -qF '#F%S' /usr/lib/libGL.so)
@@ -193,7 +169,7 @@ __EOF__
cat >> "$pkgdir"/$_mozappdir/browser/defaults/preferences/firefox-branding.js <<- EOF
// Use LANG environment variable to choose locale
- pref("intl.locale.matchOS", true);
+ pref("intl.locale.requested", "");
// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);
@@ -209,19 +185,17 @@ __EOF__
rm -f "$pkgdir"/${_mozappdirdev}/sdk/lib/libxul.so
}
-sha512sums="42abc837b5808a55e68273db6aa45fa73f8fe1df3c9072c94d8d049b6803ce8758745cc0a68af64c4ce9f86e5dd3b3619824ba67fabddce428204605894d9ee7 firefox-67.0.4.source.tar.xz
+sha512sums="fcb6f6dd8069ca43b0b75cba4566f81c94535e66ddeb80fbdd4f47eaac2efc82d6e6bd36bf7cbebdc260a74886ba3f007a321d88fdf30731d3b669a38273f42e firefox-68.0.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
-09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
-183a4ef62cd79728117797235fe46ecd3e4336c008d615c2b2a64c707477e403aed1ee5e19feb86611b93ebecc00df339aa28a73735e045e38f0d1ce3080341b fix-seccomp-bpf.patch
-ded76edfbc43637cd2e73100ea2244f97d95d452af61b9cd4f2db341cb0dbae8a5e846edeb4eafbe47dc1d30724869407d188e42b06518c67c4701745ea9adfa fix-toolkit.patch
-8de2edb1338754a0b6f1792fc795ef004cacd6223f91ba0b34f7f00471e8392f10267aacdb6a085d59bd0792abaabc42cff97ce0ccc8e546c4e7eadf6f33ec32 fix-tools.patch
-4ea267fbe395ed8865f3ec18dd129d1c78cdbf23983a9c6c9e70b0536cdf2de8953e36444a10dfbdbd522a638fd90a6a51b2f7d5396ef6c98084ddd1ea34d0ff mallinfo.patch
-3671bf7623c1825c977668efec62b57873bc6052becfd8a68ddcbc2d0ba96e0c3966c61b24716e6c48167d44280d3e690a4ff986907ceba5811a653e87770fff mozilla-build-arm.patch
-019ab248a050bef305637dc4229596c06d9596879bbb1db985b96c5a680211996d714d4a1f6e9a66544cc4562a80364b1ee37ecf7964eb974ffef2566c5c2986 disable-moz-stackwalk.patch
-42cc44fda4b05259b38f055d6f51461746aa89a474cedc5e92fb9d20879da0d12b1b515b273a549e7302cda9c7eddde20d5fdba09853e5c658784ad6d0b20078 fix-rust-target.patch
-294378108ecd8f90953beecbeb1e80bab6907d74ee1d36438a350e039b8c115093a408551fc45eb06d11f13884a6edde98eff507587b06327765047ebeb7cc8a fix-bug-1261392.patch
-40768d2458adb87fc15ad17b430cf0bebabde583910e55624bf282d4a69b3f9b9165289a7a9c2b50bfb9de1a16e2546f8d0b5ce33c1920000cffb588410b9e9e fix-webrtc-glibcisms.patch
-e725a6e9b2361cd566ae2f90861dbce9f2231f16721ec02f4b9f9986b7dc82cc006ea6a500ae7f30c095ce746132a5bd1d9532c4cf0d1541dcc672a20aef8807 sandbox-membarrier.patch
+84b84d2d7dbc16002510bf856796ad345ac38ef6d3254670230189bba7c2d4781714d231236d5a3d70129a4597b430c3171644b01ad0f5a5bb13b55d407337a4 fix-seccomp-bpf.patch
+2c65ea7280e6e89826ebad563ee25203a99ff0b4ba8fc60ec261ada6c69874d649c6ac92fcecc6307a6e5a00de27d7956acf944d556ddfadec0411be16f4e0b8 fix-toolkit.patch
+4d55f41d15be7457ad630f8f07e4fc0314c2f75720010b4bbe6a2a7f3228210a1e069949e11795efbe2e784b0762e79fdfe5b8ec38e8a64cb8d9cf3b57dd5af1 fix-tools.patch
+a4a3e062661bda64d502d426c480ac9645345860118de9df9ffe6e0597738c70c11e5cdef2d4fd12c5e2ee30a09310159230524655a419a4f7e4eeeb0f3c06b0 mallinfo.patch
+454ea3263cabce099accbdc47aaf83be26a19f8b5a4568c01a7ef0384601cf8315efd86cd917f9c8bf419c2c845db89a905f3ff9a8eb0c8e41042e93aa96a85c disable-moz-stackwalk.patch
+e0df4fc649012f023443ce9165da29d36459dbca5df64a31008b28d96264fba909858de36d0cf1b1cb1aab898342413f0cd77c90ebe21d1f9a0504631d6d1d0e fix-musl.patch
+676c47e3dc25b059a2efcc7bbb0e7748be7f8a908d1ed6c4d81a0930a35ed28566bdc738b84e13fd11c0e7f07ab1a1969caa06b3acf9b95002eb6b3beb30b82c fix-rust-target.patch
+d35cacb9ede80e6bfbef0709823e536dddfb1c02d776275b0b7adb5969e9927d8c6117df96873569c3f3db0a18ee5db24f8086a9311a05077892be43a3dd8d79 fix-webrtc-glibcisms.patch
+f85f2c19c3dafab915bcb40e580fc442fd9eab5916696849edf0b105c758dd807dfe23a6479935613c81496711eb377c73227c03eb8582204c3442a4d0e397a2 fix-sandbox-membarrier.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/testing/firefox/disable-moz-stackwalk.patch b/testing/firefox/disable-moz-stackwalk.patch
index bbd3e31b2f..b6bc756d2b 100644
--- a/testing/firefox/disable-moz-stackwalk.patch
+++ b/testing/firefox/disable-moz-stackwalk.patch
@@ -2,7 +2,7 @@ diff --git a/mozglue/misc/StackWalk.cpp b/mozglue/misc/StackWalk.cpp
index 7d62921..adcfa44 100644
--- a/mozglue/misc/StackWalk.cpp
+++ b/mozglue/misc/StackWalk.cpp
-@@ -32,13 +32,7 @@ using namespace mozilla;
+@@ -33,13 +33,7 @@ using namespace mozilla;
# define MOZ_STACKWALK_SUPPORTS_MACOSX 0
#endif
diff --git a/testing/firefox/fix-bug-1261392.patch b/testing/firefox/fix-bug-1261392.patch
deleted file mode 100644
index cf5d8a0b1c..0000000000
--- a/testing/firefox/fix-bug-1261392.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/tools/profiler/core/platform.h b/tools/profiler/core/platform.h
-index 8379eb0347..4246d8138c 100644
---- a/tools/profiler/core/platform.h
-+++ b/tools/profiler/core/platform.h
-@@ -39,10 +39,11 @@
- #include <functional>
- #include <stdint.h>
-
--// We need a definition of gettid(), but old glibc versions don't provide a
--// wrapper for it.
--#if defined(__GLIBC__)
-+// We need a definition of gettid(), but Linux libc implementations don't
-+// provide a wrapper for it (except for Bionic)
-+#if defined(__linux__)
- # include <unistd.h>
-+#if !defined(__BIONIC__)
- # include <sys/syscall.h>
- # define gettid() static_cast<pid_t>(syscall(SYS_gettid))
- #elif defined(GP_OS_darwin)
-@@ -58,6 +59,7 @@
- # define getpid _getpid
- # endif
- #endif
-+#endif
-
- extern mozilla::LazyLogModule gProfilerLog;
-
diff --git a/testing/firefox/fix-fortify-inline.patch b/testing/firefox/fix-fortify-inline.patch
deleted file mode 100644
index 2498c57fc7..0000000000
--- a/testing/firefox/fix-fortify-inline.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/media/webrtc/signaling/src/sdp/sipcc/sdp_os_defs.h
-+++ b/media/webrtc/signaling/src/sdp/sipcc/sdp_os_defs.h
-@@ -27,8 +27,5 @@
- typedef int16_t int16;
- typedef unsigned short ushort;
- typedef unsigned long ulong;
--#ifndef __GNUC_STDC_INLINE__
--#define inline
--#endif
-
- #endif /* _SDP_OS_DEFS_H_ */
diff --git a/testing/firefox/fix-musl.patch b/testing/firefox/fix-musl.patch
new file mode 100644
index 0000000000..996a45f130
--- /dev/null
+++ b/testing/firefox/fix-musl.patch
@@ -0,0 +1,11 @@
+--- a/tools/profiler/core/platform-linux-android.cpp 2019-07-09 22:58:30.039475686 +0200
++++ b/tools/profiler/core/platform-linux-android.cpp 2019-07-09 22:58:39.331437677 +0200
+@@ -73,7 +73,7 @@
+
+ int profiler_current_thread_id() {
+ // glibc doesn't provide a wrapper for gettid().
+-#if defined(__GLIBC__)
++#if defined(__linux__)
+ return static_cast<int>(static_cast<pid_t>(syscall(SYS_gettid)));
+ #else
+ return static_cast<int>(gettid());
diff --git a/testing/firefox/fix-rust-target.patch b/testing/firefox/fix-rust-target.patch
index 7dd760ca1d..8c4b6739ab 100644
--- a/testing/firefox/fix-rust-target.patch
+++ b/testing/firefox/fix-rust-target.patch
@@ -1,6 +1,6 @@
--- a/build/moz.configure/rust.configure
+++ b/build/moz.configure/rust.configure
-@@ -181,9 +181,11 @@
+@@ -280,9 +280,11 @@
die("Don't know how to translate {} for rustc".format(
host_or_target.alias))
@@ -13,7 +13,7 @@
in_fd, in_path = mkstemp(prefix='conftest', suffix='.rs')
out_fd, out_path = mkstemp(prefix='conftest', suffix='.rlib')
os.close(out_fd)
-@@ -220,7 +222,7 @@
+@@ -319,7 +321,7 @@
os.remove(out_path)
# This target is usable.
diff --git a/testing/firefox/sandbox-membarrier.patch b/testing/firefox/fix-sandbox-membarrier.patch
index 24b70ca401..4bd3b80d2a 100644
--- a/testing/firefox/sandbox-membarrier.patch
+++ b/testing/firefox/fix-sandbox-membarrier.patch
@@ -4,7 +4,7 @@ Taken from voidlinux: https://github.com/void-linux/void-packages/commit/4198411
--- a/security/sandbox/linux/SandboxFilter.cpp
+++ b/security/sandbox/linux/SandboxFilter.cpp
-@@ -283,6 +283,8 @@
+@@ -572,6 +572,8 @@
case __NR_set_tid_address:
return Allow();
#endif
diff --git a/testing/firefox/fix-seccomp-bpf.patch b/testing/firefox/fix-seccomp-bpf.patch
index ae3ba5d44b..de7bd175ee 100644
--- a/testing/firefox/fix-seccomp-bpf.patch
+++ b/testing/firefox/fix-seccomp-bpf.patch
@@ -1,6 +1,5 @@
-diff -ru firefox-62.0.3.orig/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc firefox-62.0.3/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc
---- firefox-62.0.3.orig/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc 2018-12-14 08:53:46.083976137 +0000
-+++ firefox-62.0.3/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc 2018-12-14 08:51:22.084596411 +0000
+--- a/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc 2018-12-14 08:53:46.083976137 +0000
++++ b/security/sandbox/chromium/sandbox/linux/seccomp-bpf/trap.cc 2018-12-14 08:51:22.084596411 +0000
@@ -25,6 +25,11 @@
#include "sandbox/linux/system_headers/linux_seccomp.h"
#include "sandbox/linux/system_headers/linux_signal.h"
@@ -13,14 +12,3 @@ diff -ru firefox-62.0.3.orig/security/sandbox/chromium/sandbox/linux/seccomp-bpf
namespace {
struct arch_sigsys {
-diff -ru firefox-62.0.3.orig/security/sandbox/linux/SandboxFilter.cpp firefox-62.0.3/security/sandbox/linux/SandboxFilter.cpp
---- firefox-62.0.3.orig/security/sandbox/linux/SandboxFilter.cpp 2018-10-01 18:35:28.000000000 +0000
-+++ firefox-62.0.3/security/sandbox/linux/SandboxFilter.cpp 2018-12-14 08:57:50.645264590 +0000
-@@ -997,6 +997,7 @@ class ContentSandboxPolicy : public SandboxPolicyCommon {
- // ffmpeg, and anything else that calls isatty(), will be told
- // that nothing is a typewriter:
- .ElseIf(request == TCGETS, Error(ENOTTY))
-+ .ElseIf(request == TIOCGWINSZ, Error(ENOTTY))
- // Allow anything that isn't a tty ioctl, for now; bug 1302711
- // will cover changing this to a default-deny policy.
- .ElseIf(shifted_type != kTtyIoctls, Allow())
diff --git a/testing/firefox/fix-stack-overflow.patch b/testing/firefox/fix-stack-overflow.patch
deleted file mode 100644
index e164fc69b6..0000000000
--- a/testing/firefox/fix-stack-overflow.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-https://bugs.alpinelinux.org/issues/5559
-https://bugzilla.mozilla.org/show_bug.cgi?id=1274732
-
-diff --git a/netwerk/streamconv/converters/nsHTTPCompressConv.cpp b/netwerk/streamconv/converters/nsHTTPCompressConv.cpp
-index 1193529..aeb96b5 100644
---- a/netwerk/streamconv/converters/nsHTTPCompressConv.cpp
-+++ b/netwerk/streamconv/converters/nsHTTPCompressConv.cpp
-@@ -165,9 +165,8 @@ nsHTTPCompressConv::BrotliHandler(nsIInputStream *stream, void *closure, const c
- nsHTTPCompressConv *self = static_cast<nsHTTPCompressConv *>(closure);
- *countRead = 0;
-
-- const uint32_t kOutSize = 128 * 1024; // just a chunk size, we call in a loop
-- unsigned char outBuffer[kOutSize];
-- unsigned char *outPtr;
-+ const size_t kOutSize = 128 * 1024; // just a chunk size, we call in a loop
-+ uint8_t *outPtr;
- size_t outSize;
- size_t avail = aAvail;
- BrotliResult res;
-@@ -177,9 +176,15 @@ nsHTTPCompressConv::BrotliHandler(nsIInputStream *stream, void *closure, const c
- return NS_OK;
- }
-
-+ auto outBuffer = MakeUniqueFallible<uint8_t[]>(kOutSize);
-+ if (outBuffer == nullptr) {
-+ self->mBrotli->mStatus = NS_ERROR_OUT_OF_MEMORY;
-+ return self->mBrotli->mStatus;
-+ }
-+
- do {
- outSize = kOutSize;
-- outPtr = outBuffer;
-+ outPtr = outBuffer.get();
-
- // brotli api is documented in brotli/dec/decode.h and brotli/dec/decode.c
- LOG(("nsHttpCompresssConv %p brotlihandler decompress %d\n", self, avail));
-@@ -210,7 +215,7 @@ nsHTTPCompressConv::BrotliHandler(nsIInputStream *stream, void *closure, const c
- nsresult rv = self->do_OnDataAvailable(self->mBrotli->mRequest,
- self->mBrotli->mContext,
- self->mBrotli->mSourceOffset,
-- reinterpret_cast<const char *>(outBuffer),
-+ reinterpret_cast<const char *>(outBuffer.get()),
- outSize);
- LOG(("nsHttpCompressConv %p BrotliHandler ODA rv=%x", self, rv));
- if (NS_FAILED(rv)) {
diff --git a/testing/firefox/fix-toolkit.patch b/testing/firefox/fix-toolkit.patch
index 706f33e867..414734dfec 100644
--- a/testing/firefox/fix-toolkit.patch
+++ b/testing/firefox/fix-toolkit.patch
@@ -2,7 +2,7 @@ diff --git a/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols
index 4222ce3..4d40c6a 100644
--- a/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
+++ b/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
-@@ -45,6 +45,7 @@
+@@ -46,6 +46,7 @@
#include <sys/mman.h>
#include <sys/stat.h>
#include <unistd.h>
@@ -42,7 +42,7 @@ diff --git a/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_sys
index 93fdad7..f34e5e0 100644
--- a/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
+++ b/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
-@@ -1134,6 +1134,12 @@ struct kernel_statfs {
+@@ -1239,6 +1239,12 @@ struct kernel_statfs {
#ifndef __NR_fallocate
#define __NR_fallocate 285
#endif
@@ -59,7 +59,7 @@ diff --git a/toolkit/mozapps/update/common/updatedefines.h b/toolkit/mozapps/upd
index 79276f7..4c67976 100644
--- a/toolkit/mozapps/update/common/updatedefines.h
+++ b/toolkit/mozapps/update/common/updatedefines.h
-@@ -102,7 +102,7 @@ static inline int mywcsprintf(WCHAR* dest, size_t count, const WCHAR* fmt,
+@@ -87,7 +87,7 @@ static inline int mywcsprintf(WCHAR* dest, size_t count, const WCHAR* fmt,
# ifdef SOLARIS
# include <sys/stat.h>
@@ -72,15 +72,15 @@ diff --git a/toolkit/mozapps/update/updater/updater.cpp b/toolkit/mozapps/update
index 257ccb4..01314e4 100644
--- a/toolkit/mozapps/update/updater/updater.cpp
+++ b/toolkit/mozapps/update/updater/updater.cpp
-@@ -3737,6 +3737,7 @@ int add_dir_entries(const NS_tchar *dirpath, ActionList *list)
- int add_dir_entries(const NS_tchar *dirpath, ActionList *list)
- {
+@@ -3978,6 +3978,7 @@
+
+ int add_dir_entries(const NS_tchar* dirpath, ActionList* list) {
int rv = OK;
+#if !defined(__linux__) || defined(__GLIBC__)
- FTS *ftsdir;
- FTSENT *ftsdirEntry;
- NS_tchar searchpath[MAXPATHLEN];
-@@ -3840,6 +3841,7 @@ int add_dir_entries(const NS_tchar *dirpath, ActionList *list)
+ FTS* ftsdir;
+ FTSENT* ftsdirEntry;
+ mozilla::UniquePtr<NS_tchar[]> searchpath(get_full_path(dirpath));
+@@ -4085,6 +4086,7 @@
}
fts_close(ftsdir);
diff --git a/testing/firefox/fix-tools.patch b/testing/firefox/fix-tools.patch
index 800b6599b3..93b9d19c84 100644
--- a/testing/firefox/fix-tools.patch
+++ b/testing/firefox/fix-tools.patch
@@ -2,7 +2,7 @@ diff --git a/tools/profiler/core/platform-linux-android.cpp b/tools/profiler/cor
index 19d0a5c56d..b64b543066 100644
--- a/tools/profiler/core/platform-linux-android.cpp
+++ b/tools/profiler/core/platform-linux-android.cpp
-@@ -498,8 +498,10 @@ static void PlatformInit(PSLockRef aLock) {}
+@@ -506,8 +506,10 @@ static void PlatformInit(PSLockRef aLock) {}
ucontext_t sSyncUContext;
void Registers::SyncPopulate() {
diff --git a/testing/firefox/fix-webrtc-glibcisms.patch b/testing/firefox/fix-webrtc-glibcisms.patch
index 46fe958e73..658b076dc8 100644
--- a/testing/firefox/fix-webrtc-glibcisms.patch
+++ b/testing/firefox/fix-webrtc-glibcisms.patch
@@ -1,13 +1,20 @@
--- ./media/webrtc/trunk/webrtc/system_wrappers/source/cpu_features_linux.c.orig 2018-05-09 23:48:44.677389171 +0200
+++ ./media/webrtc/trunk/webrtc/system_wrappers/source/cpu_features_linux.c 2018-05-09 23:48:56.254373557 +0200
-@@ -14,7 +14,9 @@
+@@ -14,7 +14,7 @@
#ifndef __GLIBC_PREREQ
#define __GLIBC_PREREQ(a, b) 0
#endif
-#if __GLIBC_PREREQ(2, 16)
-+#if !defined(__GLIBC__)
-+#include <sys/auxv.h>
-+#elif __GLIBC_PREREQ(2, 16)
++#if !__GLIBC__ || __GLIBC_PREREQ(2, 16)
#include <sys/auxv.h>
#else
#include <fcntl.h>
+@@ -32,7 +32,7 @@
+ int architecture = 0;
+ unsigned long hwcap = 0;
+ const char* platform = NULL;
+-#if __GLIBC_PREREQ(2, 16)
++#if !__GLIBC__ || __GLIBC_PREREQ(2, 16)
+ hwcap = getauxval(AT_HWCAP);
+ platform = (const char*)getauxval(AT_PLATFORM);
+ #else
diff --git a/testing/firefox/mallinfo.patch b/testing/firefox/mallinfo.patch
index 5a8b7b7340..7916a200ca 100644
--- a/testing/firefox/mallinfo.patch
+++ b/testing/firefox/mallinfo.patch
@@ -2,7 +2,7 @@ diff --git a/xpcom/base/nsMemoryReporterManager.cpp b/xpcom/base/nsMemoryReporte
index 865e1b5430..9a00dafecb 100644
--- a/xpcom/base/nsMemoryReporterManager.cpp
+++ b/xpcom/base/nsMemoryReporterManager.cpp
-@@ -123,6 +123,7 @@ static MOZ_MUST_USE nsresult ResidentUniqueDistinguishedAmount(int64_t* aN) {
+@@ -124,6 +124,7 @@ static MOZ_MUST_USE nsresult ResidentUniqueDistinguishedAmount(int64_t* aN) {
return GetProcSelfSmapsPrivate(aN);
}
@@ -10,7 +10,7 @@ index 865e1b5430..9a00dafecb 100644
# ifdef HAVE_MALLINFO
# define HAVE_SYSTEM_HEAP_REPORTER 1
static MOZ_MUST_USE nsresult SystemHeapSize(int64_t* aSizeOut) {
-@@ -142,6 +143,7 @@ static MOZ_MUST_USE nsresult SystemHeapSize(int64_t* aSizeOut) {
+@@ -143,6 +144,7 @@ static MOZ_MUST_USE nsresult SystemHeapSize(int64_t* aSizeOut) {
return NS_OK;
}
# endif
diff --git a/testing/firefox/mozilla-build-arm.patch b/testing/firefox/mozilla-build-arm.patch
deleted file mode 100644
index 8b9022ca3c..0000000000
--- a/testing/firefox/mozilla-build-arm.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./gfx/ycbcr/moz.build.orig 2014-04-03 13:50:38.990296661 +0000
-+++ ./gfx/ycbcr/moz.build 2014-04-03 13:52:26.878268547 +0000
-@@ -53,7 +53,7 @@ else:
- 'yuv_row_other.cpp',
- ]
-
--if CONFIG['CPU_ARCH'] == 'arm' and CONFIG['HAVE_ARM_NEON']:
-+if CONFIG['HAVE_ARM_NEON']:
- SOURCES += [
- 'yuv_row_arm.s',
- ]
diff --git a/testing/firefox/rust-unitialized-field.patch b/testing/firefox/rust-unitialized-field.patch
deleted file mode 100644
index 67ef3a02ab..0000000000
--- a/testing/firefox/rust-unitialized-field.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./media/audioipc/audioipc/src/cmsg.rs.orig 2018-05-09 22:19:14.748631939 +0200
-+++ ./media/audioipc/audioipc/src/cmsg.rs 2018-05-09 22:19:22.961620862 +0200
-@@ -106,11 +106,11 @@ impl ControlMsgBuilder {
- return Err(Error::NoSpace);
- }
-
-- let cmsghdr = cmsghdr {
-- cmsg_len: cmsg_len as _,
-- cmsg_level: level,
-- cmsg_type: kind,
-- };
-+ use std::mem;
-+ let mut cmsghdr: cmsghdr = unsafe { mem::zeroed() };
-+ cmsghdr.cmsg_len = cmsg_len as _;
-+ cmsghdr.cmsg_level = level;
-+ cmsghdr.cmsg_type = kind;
-
- let cmsghdr = unsafe {
- slice::from_raw_parts(&cmsghdr as *const _ as *const _, mem::size_of::<cmsghdr>())