aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/R/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index e8e8da03c4..c345e7a5b6 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -6,8 +6,7 @@ pkgver=3.4.3
pkgrel=0
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org"
-# ppc64le: segfaults in build since 3.4.3
-arch="all !s390x !ppc64le"
+arch="all !s390x"
license="GPL-2 GPL-3 LGPL-2.1"
depends="$pkgname-mathlib"
depends_dev="gcc gfortran icu-dev libjpeg-turbo libpng-dev make openblas-dev
@@ -53,8 +52,8 @@ build() {
--with-tcltk \
--with-x
- make
- make -C src/nmath/standalone
+ make -j1
+ make -j1 -C src/nmath/standalone
}
# TODO: Run provided test suite.