aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/recode/0001-avoid-gnu-error-3.patch378
-rw-r--r--main/recode/APKBUILD57
-rw-r--r--main/recode/recode-automake.patch22
-rw-r--r--main/recode/recode-bool-bitfield.patch11
-rw-r--r--main/recode/recode-flex-m4.patch16
-rw-r--r--main/recode/recode-format-security.patch12
6 files changed, 10 insertions, 486 deletions
diff --git a/main/recode/0001-avoid-gnu-error-3.patch b/main/recode/0001-avoid-gnu-error-3.patch
deleted file mode 100644
index 423ae190c5..0000000000
--- a/main/recode/0001-avoid-gnu-error-3.patch
+++ /dev/null
@@ -1,378 +0,0 @@
-From 2b46384a2f115e54fef5e5295b4ad71206649b7f Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 8 Jan 2016 15:41:08 +0000
-Subject: [PATCH] avoid gnu error(3)
-
----
- lib/Makefile.am | 4 +--
- lib/error.h | 78 ---------------------------------------------------------
- src/argmatch.c | 6 +++--
- src/common.h | 1 -
- src/main.c | 51 +++++++++++++++++++------------------
- src/xmalloc.c | 8 ++----
- 6 files changed, 34 insertions(+), 114 deletions(-)
- delete mode 100644 lib/error.h
-
-diff --git a/lib/Makefile.am b/lib/Makefile.am
-index 237fe72..36d7430 100644
---- a/lib/Makefile.am
-+++ b/lib/Makefile.am
-@@ -20,8 +20,8 @@
- AUTOMAKE_OPTIONS = gnits
-
- noinst_LIBRARIES = libreco.a
--noinst_HEADERS = error.h getopt.h gettext.h pathmax.h xstring.h
--libreco_a_SOURCES = error.c getopt.c getopt1.c xstrdup.c
-+noinst_HEADERS = xstring.h
-+libreco_a_SOURCES = xstrdup.c
-
- EXTRA_DIST = alloca.c gettext.c malloc.c realloc.c strtol.c strtoul.c
-
-diff --git a/lib/error.h b/lib/error.h
-deleted file mode 100644
-index 20f7582..0000000
---- a/lib/error.h
-+++ /dev/null
-@@ -1,78 +0,0 @@
--/* Declaration for error-reporting function
-- Copyright (C) 1995, 1996, 1997 Free Software Foundation, Inc.
--
--
-- NOTE: The canonical source of this file is maintained with the GNU C Library.
-- Bugs can be reported to bug-glibc@prep.ai.mit.edu.
--
-- This program is free software; you can redistribute it and/or modify it
-- under the terms of the GNU General Public License as published by the
-- Free Software Foundation; either version 2, or (at your option) any
-- later version.
--
-- This program is distributed in the hope that it will be useful,
-- but WITHOUT ANY WARRANTY; without even the implied warranty of
-- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-- GNU General Public License for more details.
--
-- You should have received a copy of the GNU General Public License
-- along with this program; if not, write to the Free Software
-- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
-- USA. */
--
--#ifndef _ERROR_H
--#define _ERROR_H 1
--
--#ifndef __attribute__
--/* This feature is available in gcc versions 2.5 and later. */
--# if __GNUC__ < 2 || (__GNUC__ == 2 && __GNUC_MINOR__ < 5) || __STRICT_ANSI__
--# define __attribute__(Spec) /* empty */
--# endif
--/* The __-protected variants of `format' and `printf' attributes
-- are accepted by gcc versions 2.6.4 (effectively 2.7) and later. */
--# if __GNUC__ < 2 || (__GNUC__ == 2 && __GNUC_MINOR__ < 7)
--# define __format__ format
--# define __printf__ printf
--# endif
--#endif
--
--#ifdef __cplusplus
--extern "C" {
--#endif
--
--#if defined (__STDC__) && __STDC__
--
--/* Print a message with `fprintf (stderr, FORMAT, ...)';
-- if ERRNUM is nonzero, follow it with ": " and strerror (ERRNUM).
-- If STATUS is nonzero, terminate the program with `exit (STATUS)'. */
--
--extern void error (int status, int errnum, const char *format, ...)
-- __attribute__ ((__format__ (__printf__, 3, 4)));
--
--extern void error_at_line (int status, int errnum, const char *fname,
-- unsigned int lineno, const char *format, ...)
-- __attribute__ ((__format__ (__printf__, 5, 6)));
--
--/* If NULL, error will flush stdout, then print on stderr the program
-- name, a colon and a space. Otherwise, error will call this
-- function without parameters instead. */
--extern void (*error_print_progname) (void);
--
--#else
--void error ();
--void error_at_line ();
--extern void (*error_print_progname) ();
--#endif
--
--/* This variable is incremented each time `error' is called. */
--extern unsigned int error_message_count;
--
--/* Sometimes we want to have at most one error per line. This
-- variable controls whether this mode is selected or not. */
--extern int error_one_per_line;
--
--#ifdef __cplusplus
--}
--#endif
--
--#endif /* error.h */
-diff --git a/src/argmatch.c b/src/argmatch.c
-index 9642706..daa39bd 100644
---- a/src/argmatch.c
-+++ b/src/argmatch.c
-@@ -36,7 +36,9 @@
- # define _(Text) Text
- #endif
-
--#include "error.h"
-+#include <err.h>
-+#include <stdlib.h>
-+
- #include "quotearg.h"
-
- /* When reporting an invalid argument, show nonprinting characters
-@@ -159,7 +161,7 @@ argmatch_invalid (const char *context, const char *value, int problem)
- ? _("invalid argument %s for `%s'")
- : _("ambiguous argument %s for `%s'"));
-
-- error (0, 0, format, quotearg_style (ARGMATCH_QUOTING_STYLE, value), context);
-+ warnx (format, quotearg_style (ARGMATCH_QUOTING_STYLE, value), context);
- }
-
- /* List the valid arguments for argmatch.
-diff --git a/src/common.h b/src/common.h
-index a4f56dc..089ea61 100644
---- a/src/common.h
-+++ b/src/common.h
-@@ -112,7 +112,6 @@ typedef enum {false = 0, true = 1} bool;
- #ifndef errno
- extern int errno;
- #endif
--#include "error.h"
-
- /* Generate a mask of LENGTH one-bits, right justified in a word. */
- #define MASK(Length) ((unsigned) ~(~0 << (Length)))
-diff --git a/src/main.c b/src/main.c
-index 3a5de1d..9575b32 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -23,7 +23,8 @@
- #include <sys/types.h>
- #include <sys/stat.h>
-
--#include "getopt.h"
-+#include <getopt.h>
-+#include <err.h>
-
- #if HAVE_UNISTD_H
- # include <unistd.h>
-@@ -427,11 +428,11 @@ main (int argc, char *const *argv)
- switch (argmatch (optarg, sequence_strings, NULL, 0))
- {
- case -2:
-- error (0, 0, _("Sequence `%s' is ambiguous"), optarg);
-+ warnx ( _("Sequence `%s' is ambiguous"), optarg);
- usage (EXIT_FAILURE, 0);
-
- case -1:
-- error (0, 0, _("Sequence `%s' is unknown"), optarg);
-+ warnx ( _("Sequence `%s' is unknown"), optarg);
- usage (EXIT_FAILURE, 0);
-
- case 0:
-@@ -461,11 +462,11 @@ main (int argc, char *const *argv)
- switch (argmatch (optarg, language_strings, NULL, 0))
- {
- case -2:
-- error (0, 0, _("Language `%s' is ambiguous"), optarg);
-+ warnx ( _("Language `%s' is ambiguous"), optarg);
- usage (EXIT_FAILURE, 0);
-
- default: /* -1 */
-- error (0, 0, _("Language `%s' is unknown"), optarg);
-+ warnx ( _("Language `%s' is unknown"), optarg);
- usage (EXIT_FAILURE, 0);
-
- case 0:
-@@ -519,11 +520,11 @@ main (int argc, char *const *argv)
- switch (argmatch (buffer, language_strings, NULL, 0))
- {
- case -2:
-- error (0, 0, _("Language `%s' is ambiguous"), buffer);
-+ warnx ( _("Language `%s' is ambiguous"), buffer);
- usage (EXIT_FAILURE, 0);
-
- default: /* -1 */
-- error (0, 0, _("Language `%s' is unknown"), buffer);
-+ warnx ( _("Language `%s' is unknown"), buffer);
- usage (EXIT_FAILURE, 0);
-
- case 0:
-@@ -557,11 +558,11 @@ main (int argc, char *const *argv)
- switch (argmatch (optarg, format_strings, NULL, 0))
- {
- case -2:
-- error (0, 0, _("Format `%s' is ambiguous"), optarg);
-+ warnx ( _("Format `%s' is ambiguous"), optarg);
- usage (EXIT_FAILURE, 0);
-
- case -1:
-- error (0, 0, _("Format `%s' is unknown"), optarg);
-+ warnx ( _("Format `%s' is unknown"), optarg);
- usage (EXIT_FAILURE, 0);
-
- case 0:
-@@ -666,7 +667,7 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
-
- if (!alias)
- {
-- error (0, 0, _("Symbol `%s' is unknown"), ignored_name);
-+ warnx ( _("Symbol `%s' is unknown"), ignored_name);
- usage (EXIT_FAILURE, 1);
- }
-
-@@ -688,12 +689,12 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
- if (charset_restrictions)
- if (!decode_known_pairs (outer, charset_restrictions))
- {
-- error (0, 0, "Could not understand `%s'", charset_restrictions);
-+ warnx ( "Could not understand `%s'", charset_restrictions);
- usage (EXIT_FAILURE, 0);
- }
- if (optind + 1 < argc)
- {
-- error (0, 0, "Argument `%s' is extraneous", argv[optind]);
-+ warnx ( "Argument `%s' is extraneous", argv[optind]);
- usage (EXIT_FAILURE, 0);
- }
-
-@@ -706,7 +707,7 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
-
- if (!alias)
- {
-- error (0, 0, _("Charset `%s' is unknown or ambiguous"),
-+ warnx ( _("Charset `%s' is unknown or ambiguous"),
- argv[optind]);
- usage (EXIT_FAILURE, 1);
- }
-@@ -720,7 +721,7 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
-
- if (!alias)
- {
-- error (0, 0, _("Charset `%s' is unknown or ambiguous"),
-+ warnx ( _("Charset `%s' is unknown or ambiguous"),
- argv[optind]);
- usage (EXIT_FAILURE, 1);
- }
-@@ -751,7 +752,7 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
-
- if (optind + 1 > argc)
- {
-- error (0, 0, _("Required argument is missing"));
-+ warnx ( _("Required argument is missing"));
- usage (EXIT_FAILURE, 0);
- }
-
-@@ -794,13 +795,13 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
-
- user_request = rewritten_request;
- if (!quiet_flag)
-- error (0, 0, _("Syntax is deprecated, please prefer `%s'"),
-+ warnx ( _("Syntax is deprecated, please prefer `%s'"),
- user_request);
- }
- }
-
- if (!recode_scan_request (request, user_request))
-- error (EXIT_FAILURE, 0, _("Request `%s' is erroneous"), user_request);
-+ errx (EXIT_FAILURE, _("Request `%s' is erroneous"), user_request);
- if (rewritten_request)
- free (rewritten_request);
- }
-@@ -857,7 +858,7 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
- /* Check if the file can be read and rewritten. */
-
- if (file = fopen (input_name, "r+"), file == NULL)
-- error (EXIT_FAILURE, errno, "fopen (%s)", input_name);
-+ err (EXIT_FAILURE, "fopen (%s)", input_name);
-
- /* Save the input file attrobites. */
-
-@@ -917,22 +918,22 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
- /* Move the new file over the original. */
-
- if (unlink (input_name) < 0)
-- error (EXIT_FAILURE, errno, "unlink (%s)", input_name);
-+ err (EXIT_FAILURE, "unlink (%s)", input_name);
-
- /* Preserve the file permissions. */
-
- if (chmod (output_name, file_stat.st_mode & 07777) < 0)
-- error (EXIT_FAILURE, errno, "chmod (%s)", output_name);
-+ err (EXIT_FAILURE, "chmod (%s)", output_name);
- #if HAVE_RENAME
- if (rename (output_name, input_name) < 0)
-- error (EXIT_FAILURE, errno, "rename (%s, %s)",
-+ err (EXIT_FAILURE, "rename (%s, %s)",
- output_name, input_name);
- #else
- if (link (output_name, input_name) < 0)
-- error (EXIT_FAILURE, errno, "link (%s, %s)",
-+ err (EXIT_FAILURE, "link (%s, %s)",
- output_name, input_name);
- if (unlink (output_name) < 0)
-- error (EXIT_FAILURE, errno, "unlink (%s)", output_name);
-+ err (EXIT_FAILURE, "unlink (%s)", output_name);
- #endif
-
- /* Adjust the time stamp for the new file. */
-@@ -958,7 +959,7 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
- fflush (stderr);
- }
- else if (!quiet_flag)
-- error (0, 0, _("%s failed: %s in step `%s..%s'"),
-+ warnx ( _("%s failed: %s in step `%s..%s'"),
- input_name, task_perror (task),
- task->error_at_step->before->name,
- task->error_at_step->after->name);
-@@ -981,7 +982,7 @@ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"),
- {
- success = false;
- if (!quiet_flag)
-- error (0, 0, _("%s in step `%s..%s'"),
-+ warnx ( _("%s in step `%s..%s'"),
- task_perror (task),
- task->error_at_step->before->name,
- task->error_at_step->after->name);
-diff --git a/src/xmalloc.c b/src/xmalloc.c
-index 8206a94..9c5080e 100644
---- a/src/xmalloc.c
-+++ b/src/xmalloc.c
-@@ -20,6 +20,7 @@
- #endif
-
- #include <sys/types.h>
-+#include <err.h>
-
- #if STDC_HEADERS
- # include <stdlib.h>
-@@ -39,7 +40,6 @@ void free ();
- #endif
- #define N_(Text) Text
-
--#include "error.h"
- #include "xalloc.h"
-
- #ifndef EXIT_FAILURE
-@@ -70,11 +70,7 @@ xalloc_die (void)
- {
- if (xalloc_fail_func)
- (*xalloc_fail_func) ();
-- error (xalloc_exit_failure, 0, "%s", _(xalloc_msg_memory_exhausted));
-- /* The `noreturn' cannot be given to error, since it may return if
-- its first argument is 0. To help compilers understand the
-- xalloc_die does terminate, call exit. */
-- exit (EXIT_FAILURE);
-+ errx (xalloc_exit_failure, "%s", _(xalloc_msg_memory_exhausted));
- }
-
- /* Allocate N bytes of memory dynamically, with error checking. */
---
-2.7.0
-
diff --git a/main/recode/APKBUILD b/main/recode/APKBUILD
index e2b379348e..267ce092ce 100644
--- a/main/recode/APKBUILD
+++ b/main/recode/APKBUILD
@@ -1,42 +1,25 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=recode
-pkgver=3.6
-pkgrel=2
+pkgver=3.7.6
+pkgrel=0
pkgdesc="Charset converter tool and library"
url="https://github.com/pinard/Recode"
arch="all"
license="GPL-2.0-or-later"
-depends=""
-depends_dev=""
-makedepends="$depends_dev libtool automake autoconf texinfo flex bison"
-install=""
+makedepends="libtool automake autoconf texinfo flex bison gettext-dev
+ python3"
subpackages="$pkgname-dev $pkgname-doc"
-source="Recode-$pkgver.tar.gz::https://github.com/pinard/Recode/archive/v$pkgver.tar.gz
- recode-automake.patch
- recode-bool-bitfield.patch
- recode-flex-m4.patch
- recode-format-security.patch
- 0001-avoid-gnu-error-3.patch
+source="https://github.com/rrthomas/recode/releases/download/v$pkgver/recode-$pkgver.tar.gz
"
-_builddir="$srcdir"/Recode-$pkgver
prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
rm -f acinclude.m4 m4/libtool.m4
autoreconf -vif
}
build() {
- cd "$_builddir"
- CFLAGS="$CFLAGS -std=gnu89" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -47,32 +30,12 @@ build() {
--localstatedir=/var \
--disable-nls \
--disable-static \
- --without-included-gettext \
- || return 1
- make || return 1
+ --without-included-gettext
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/charset.alias
+ make DESTDIR="$pkgdir" install
}
-md5sums="977d5e836dc6540b120d00ecdf14d25d Recode-3.6.tar.gz
-0c9269360d3671e8bc865a16a6243fdd recode-automake.patch
-b2b69d392dbb6ba45b77873d3a3b6ce6 recode-bool-bitfield.patch
-ed5fa897383f1a8f3b15236d2487d3bc recode-flex-m4.patch
-3ab25ae6bba23ddce1c85ed2af251e03 recode-format-security.patch
-0534962f3ee5018046c5504982624d0d 0001-avoid-gnu-error-3.patch"
-sha256sums="1f0c859350a5fb3c555a7b80080e3238bbf2f0dc50f4009af0a407b3e2865503 Recode-3.6.tar.gz
-dbe524a4bed3901549294089f05fd05b83cf4517541139622e00fc041de952d5 recode-automake.patch
-d48b94231ab9b866dc1abf73de55a5535c8c754751a038fdaf75f3082593a06b recode-bool-bitfield.patch
-b3364355bee4f2ea0939ec0a9d924ab6efa923967daf5ea064fdb1750aef6990 recode-flex-m4.patch
-715731dbf03afbf5be8226a808da75b96180f825d31bba74ed8b9851283e042a recode-format-security.patch
-94172af72807ed15c8ef9acde2297ba571e78327a7599e62afb5c7b76df2f530 0001-avoid-gnu-error-3.patch"
-sha512sums="0d2ea3e340811ce1172d1a934af20030fb69a940cc86ab6f1bb90a2f81869b91c7f7d2ce503b527d47228140604c465d08661f4f39ae5bdcb28beef1388c3a17 Recode-3.6.tar.gz
-628e3cfddc30c5c4cae5de0a67d9f2539f334a096e8dfaf2aaec04449e1c1f49ab1701a7998d9029506e2935e169fa07c7fbb418c97cbc48497a906f8dc304c8 recode-automake.patch
-b10aa58b2da7a3991d9894bde775ce3ae18d3ab5b6db7941824e0dba871cb30c3c530d32dedfd9be1c7fdd874f956819341c53ae946962441b3b84e1dbebee33 recode-bool-bitfield.patch
-edb4f9a380744ffdabb5775a2d2cfaaa04f491b2fafa7c47f32197394e03607d48c00dcf19a24b486665bd510428a3ba4e4030e3ebd7f832bb453865c69bd868 recode-flex-m4.patch
-093314da6eb2666dcf7a8268366204669aa82df4e5455f28982595a60025d0ccadc989f08868c7ff4d4f49f3298395ce228fa848aed0dcb470063d07ea1dfae1 recode-format-security.patch
-f14c90429c98e39f101e86fbc090eaae88e25c6d912865416d19d53ff50a1a5ba77d73e31861cd3be3c70b5dd12d2770f211ed338b67ee0747bfc6c35b1358a9 0001-avoid-gnu-error-3.patch"
+sha512sums="ababefc445fcc47b6bf9ed640b767aed374bb8ce93cdccb641dd1ba5d298360583dd79070a0bb458f1190a8d6f1ddeb3b04eec34a61305b69def0963cec5843f recode-3.7.6.tar.gz"
diff --git a/main/recode/recode-automake.patch b/main/recode/recode-automake.patch
deleted file mode 100644
index d0916c8cbb..0000000000
--- a/main/recode/recode-automake.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- recode-3.6.orig/configure.in 2001-01-03 16:50:54.000000000 +0100
-+++ recode-3.6/configure.in 2012-07-23 14:15:28.000000000 +0200
-@@ -15,7 +15,7 @@
- AM_PROG_LIBTOOL
-
- AC_ISC_POSIX
--AM_C_PROTOTYPES
-+dnl AM_C_PROTOTYPES
- AC_C_CONST
- AC_C_INLINE
- ad_AC_PROG_FLEX
---- recode-3.6.orig/src/Makefile.am 2000-12-06 17:36:12.000000000 +0100
-+++ recode-3.6/src/Makefile.am 2012-07-23 14:47:07.000000000 +0200
-@@ -17,7 +17,7 @@
- # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
- # 02111-1307, USA.
-
--AUTOMAKE_OPTIONS = gnits ansi2knr
-+AUTOMAKE_OPTIONS = gnits
- bin_PROGRAMS = recode
- lib_LTLIBRARIES = librecode.la
- man_MANS = recode.1
diff --git a/main/recode/recode-bool-bitfield.patch b/main/recode/recode-bool-bitfield.patch
deleted file mode 100644
index 899edc5d7b..0000000000
--- a/main/recode/recode-bool-bitfield.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/recodext.h.orig 2008-01-16 13:15:39.000000000 +0100
-+++ b/src/recodext.h 2008-01-16 13:16:47.000000000 +0100
-@@ -218,7 +218,7 @@
- enum recode_symbol_type type : 3;
-
- /* Non zero if this one should be ignored. */
-- bool ignore : 2;
-+ bool ignore : 1;
- };
-
- struct recode_surface_list
diff --git a/main/recode/recode-flex-m4.patch b/main/recode/recode-flex-m4.patch
deleted file mode 100644
index e63bdbf25c..0000000000
--- a/main/recode/recode-flex-m4.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- recode-3.6-orig/m4/flex.m4 2000-06-28 16:39:06.000000000 +0200
-+++ recode-3.6/m4/flex.m4 2010-07-07 12:23:49.000000000 +0200
-@@ -8,11 +8,8 @@
- dnl Look for flex or missing, then run AC_PROG_LEX and AC_DECL_YYTEXT
- AC_DEFUN(ad_AC_PROG_FLEX,
- [AC_CHECK_PROGS(LEX, flex, missing)
--if test "$LEX" = missing; then
-+AS_IF([test "$LEX" = missing], [
- LEX="\$(top_srcdir)/$ac_aux_dir/missing flex"
- LEX_OUTPUT_ROOT=lex.yy
- AC_SUBST(LEX_OUTPUT_ROOT)dnl
--else
-- AC_PROG_LEX
-- AC_DECL_YYTEXT
--fi])
-+])])
diff --git a/main/recode/recode-format-security.patch b/main/recode/recode-format-security.patch
deleted file mode 100644
index 756ba3ff56..0000000000
--- a/main/recode/recode-format-security.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up recode-3.6/src/names.c.printf recode-3.6/src/names.c
---- recode-3.6/src/names.c.printf 2000-12-06 20:41:29.000000000 +0100
-+++ recode-3.6/src/names.c 2013-12-18 12:48:42.578052395 +0100
-@@ -892,7 +892,7 @@ list_concise_charset (RECODE_OUTER outer
- if (ucs2 >= 0)
- printf (format, code);
- else if (mnemonic || counter2 != 112)
-- printf (blanks);
-+ printf ("%s", blanks);
-
- if (mnemonic)
- printf (counter2 == 112 ? " %s\n" : " %-3s", mnemonic);