aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/gjs/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/gjs/APKBUILD b/community/gjs/APKBUILD
index 2730fbe8d9..c4f1d0c5c1 100644
--- a/community/gjs/APKBUILD
+++ b/community/gjs/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gjs
pkgver=1.58.3
-pkgrel=0
+pkgrel=1
pkgdesc="GNOME javascript library"
url="https://wiki.gnome.org/Projects/Gjs"
arch="all !s390x"
license="MIT LGPL-2.0-or-later"
makedepends="$depends_dev dbus gobject-introspection-dev mozjs60-dev mozjs60
gtk+3.0-dev cairo-dev"
-options="!check" # needs DISPLAY
+checkdepends="xvfb-run"
+options="!check" # testCommandLine.sh fails
subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/gjs/${pkgver%.*}/gjs-$pkgver.tar.xz"
@@ -26,7 +27,7 @@ build() {
}
check() {
- make check
+ xvfb-run make check
}
package() {