aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/micropython/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index cd003b4e4a..65ca7ea82b 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -2,13 +2,16 @@
# Maintainer: Marian <marian.buschsieweke@ovgu.de>
pkgname=micropython
pkgver=1.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="A lean and efficient Python implementation for MCUs and constrained systems"
url="http://www.micropython.org/"
-arch="all"
+
+# ../py/persistentcode.c:397:2: error: #error mp_raw_code_save_file not implemented for this platform
+arch="x86 x86_64 armhf"
+
license="MIT"
depends=""
-makedepends="libffi-dev python3 python2"
+makedepends="libffi-dev python3"
subpackages=""
source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz
0000-unix-mpconfigport.patch
@@ -18,8 +21,7 @@ builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
cd "$builddir"
- unset CFLAGS
- make -C unix #PYTHON=python3
+ make -C unix PYTHON=python3
}
check() {
@@ -28,7 +30,7 @@ check() {
# ffi callback fails on kernel with PaX
rm tests/unix/ffi_callback.py
- make -C unix test #PYTHON=python3
+ make -C unix test PYTHON=python3
}
package() {