aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/keysmith/APKBUILD (renamed from testing/keysmith/APKBUILD)20
1 files changed, 6 insertions, 14 deletions
diff --git a/testing/keysmith/APKBUILD b/community/keysmith/APKBUILD
index aa45b0156f..bcb8e82172 100644
--- a/testing/keysmith/APKBUILD
+++ b/community/keysmith/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname="keysmith"
-pkgver="0.1"
+pkgname=keysmith
+pkgver=0.1
pkgrel=1
pkgdesc="OTP client for Plasma Mobile and Desktop"
url="https://invent.kde.org/kde/keysmith"
@@ -11,28 +11,20 @@ depends="kirigami2"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev qt5-qtquickcontrols2-dev oath-toolkit-dev kirigami2-dev"
source="https://download.kde.org/stable/keysmith/$pkgver/keysmith-$pkgver.tar.xz"
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
-
build() {
- cd "$builddir"/build
- cmake "$builddir" \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake --build build
}
check() {
- cd "$builddir"/build
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
sha512sums="a381cfe12b98188f58a012ec6a1872dc52ff024b6dd81ebb6e1ba5af5fc7bdcca8231178db7a9290be66d9f24f48fce93080b15a175e50a0b35d0fdf11d10fea keysmith-0.1.tar.xz"