aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/fs-uae/APKBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/testing/fs-uae/APKBUILD b/testing/fs-uae/APKBUILD
index 9193103909..9efb5af48d 100644
--- a/testing/fs-uae/APKBUILD
+++ b/testing/fs-uae/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Taner Tas <taner76@gmail.com>
pkgname=fs-uae
pkgver=2.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="Amiga emulator."
url="https://fs-uae.net/"
-arch="all !ppc64le !armhf !aarch64" # --enable-jit not supported for these arches
+arch="all !armhf !aarch64" # --enable-jit not supported for these arches
license="GPL-2.0-only"
makedepends="zip clang-dev sdl2-dev libpng-dev libx11-dev libxi-dev openal-soft-dev linux-headers libmpeg2-dev glib-dev"
subpackages="$pkgname-lang"
@@ -15,7 +15,16 @@ options="!check"
build() {
export CC=clang
export CXX=clang++
+ local _jitoptions=
unset CFLAGS CXXFLAGS
+ case "$CARCH" in
+ ppc64le)
+ _jitoptions="--disable-jit"
+ export CFLAGS="-g -O2 -U__ALTIVEC__"
+ export CXXFLAGS="-g -O2 -U__ALTIVEC__"
+ ;;
+ esac
+
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -23,6 +32,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
+ $_jitoptions \
--enable-sdl2
make
}