aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/brillo/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/brillo/APKBUILD b/testing/brillo/APKBUILD
new file mode 100644
index 0000000000..faab59f95c
--- /dev/null
+++ b/testing/brillo/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=brillo
+pkgver=1.4.9
+pkgrel=0
+pkgdesc="Control the brightness of backlight and keyboard LED devices"
+options="!check"
+url="https://gitlab.com/cameronnemo/brillo"
+arch="all"
+license="0BSD"
+makedepends="go-md2man"
+checkdepends="valgrind"
+subpackages="$pkgname-doc"
+source="https://gitlab.com/cameronnemo/brillo/-/archive/v$pkgver/brillo-v$pkgver.tar.gz"
+builddir="$srcdir/brillo-v$pkgver"
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install install.polkit
+}
+
+sha512sums="444f173bf6d1bcbb1598979e906656adf322e036372ac11553e23152d3bfc3b8c0aa5839e2069e095eafab3993a975e4247418f3828760c9c3cd29a6a092327b brillo-v1.4.9.tar.gz"