aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ceph/APKBUILD1
-rw-r--r--community/gdnsd/APKBUILD16
-rw-r--r--community/gvm-libs/APKBUILD2
-rw-r--r--community/imagemagick/APKBUILD2
-rw-r--r--community/llvm5/APKBUILD1
-rw-r--r--community/mingw-w64-gcc/APKBUILD3
-rw-r--r--community/pdsh/APKBUILD1
-rw-r--r--community/repmgr/APKBUILD4
-rw-r--r--community/restic/APKBUILD7
-rw-r--r--community/tcsh/APKBUILD1
-rw-r--r--community/vlc/APKBUILD1
-rw-r--r--community/yadifa/APKBUILD1
12 files changed, 10 insertions, 30 deletions
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index a0fe84f21d..7c64141ed1 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -11,7 +11,6 @@ arch="x86_64 aarch64"
# https://github.com/ceph/ceph/blob/master/COPYING
license="LGPL-2.1-only AND LGPL-2.0-or-later AND GPL-2.0-only AND GPL-3.0-only AND CC-BY-SA-1.0 AND BSL-1.0 AND GPL-2.0-or-later WITH Autoconf-exception-2.0 AND BSD-3-Clause AND MIT AND custom"
depends="ceph-osd ceph-mds ceph-mon"
-options="!checkroot"
_base_deps="
cryptsetup
e2fsprogs
diff --git a/community/gdnsd/APKBUILD b/community/gdnsd/APKBUILD
index 54900b757a..394c4e6212 100644
--- a/community/gdnsd/APKBUILD
+++ b/community/gdnsd/APKBUILD
@@ -2,22 +2,18 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=gdnsd
pkgver=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Geographic Authoritative DNS server"
url="https://github.com/blblack/gdnsd/"
arch="all"
-license="GPL-3.0"
-depends=""
-depends_dev=""
-options="!checkroot"
+license="GPL-3.0-or-later"
makedepends="userspace-rcu-dev libev-dev libcap-dev libmaxminddb-dev ragel autoconf automake libtool"
checkdepends="perl perl-libwww perl-socket6 perl-io-socket-inet6 perl-http-daemon perl-test-harness perl-test-harness-utils"
install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/gdnsd/gdnsd/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz
+source="https://github.com/gdnsd/gdnsd/releases/download/v$pkgver/gdnsd-$pkgver.tar.xz
gdnsd.initd"
-builddir="$srcdir"/gdnsd-$pkgver
prepare() {
default_prepare
@@ -25,7 +21,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -37,15 +32,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm755 "$srcdir"/gdnsd.initd \
- "$pkgdir"/etc/init.d/gdnsd
+ install -Dm755 "$srcdir"/gdnsd.initd "$pkgdir"/etc/init.d/gdnsd
}
sha512sums="be7a93901283abe0c4304456263d75b81e3a4141be37c4eaa0149e757dca60cef26a926a6134f6e3ef67da5be70bfd3be78f37a8b3788c75e81f421ae744de53 gdnsd-2.4.0.tar.xz
diff --git a/community/gvm-libs/APKBUILD b/community/gvm-libs/APKBUILD
index c00b7d10e4..e389822d90 100644
--- a/community/gvm-libs/APKBUILD
+++ b/community/gvm-libs/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Greenbone Vulnerability Management Libraries"
url="https://www.openvas.org/"
arch="all"
license="GPL-2.0-or-later"
-options="!nocheck" # test fails: https://github.com/greenbone/gvm-libs/issues/279
+options="!check" # test fails: https://github.com/greenbone/gvm-libs/issues/279
pkgusers="gvm"
pkggroups="gvm"
install="$pkgname.pre-install"
diff --git a/community/imagemagick/APKBUILD b/community/imagemagick/APKBUILD
index 4e3489f5a7..fcc7d3515e 100644
--- a/community/imagemagick/APKBUILD
+++ b/community/imagemagick/APKBUILD
@@ -11,7 +11,7 @@ pkgdesc="Collection of tools and libraries for many image formats"
url="https://www.imagemagick.org/"
arch="all"
license="ImageMagick"
-options="libtool !checkroot"
+options="libtool"
makedepends="zlib-dev libpng-dev libjpeg-turbo-dev freetype-dev fontconfig-dev
perl-dev ghostscript-dev libtool tiff-dev lcms2-dev
libwebp-dev libxml2-dev libx11-dev libxext-dev chrpath
diff --git a/community/llvm5/APKBUILD b/community/llvm5/APKBUILD
index 36bfdb71f8..6e99ec4d53 100644
--- a/community/llvm5/APKBUILD
+++ b/community/llvm5/APKBUILD
@@ -26,7 +26,6 @@ source="https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz
fix-too-strict-gtest-banner-check.patch
"
builddir="$srcdir/$_pkgname-$pkgver.src"
-options="!checkroot"
# ARM has few failures in test suite that we don't care about currently and
# also it takes forever to run them on the builder.
diff --git a/community/mingw-w64-gcc/APKBUILD b/community/mingw-w64-gcc/APKBUILD
index 8905ae84b6..111ab45ccf 100644
--- a/community/mingw-w64-gcc/APKBUILD
+++ b/community/mingw-w64-gcc/APKBUILD
@@ -5,7 +5,6 @@ pkgver=9.2.0
pkgrel=1
_islver=0.21
pkgdesc="Cross GCC for the MinGW-w64 cross-compiler"
-options="!static"
url="https://gcc.gnu.org"
arch="x86_64 x86"
license="GPL-3.0-or-later"
@@ -39,7 +38,7 @@ build() {
"$builddir"/configure \
--prefix=/usr \
--libexecdir=/usr/libexec \
- --target=${_target} \
+ --target=$_target \
--enable-languages=c,lto,c++ \
--enable-shared --enable-static \
--enable-threads=posix --enable-fully-dynamic-string \
diff --git a/community/pdsh/APKBUILD b/community/pdsh/APKBUILD
index a009f72a48..52bcce65c7 100644
--- a/community/pdsh/APKBUILD
+++ b/community/pdsh/APKBUILD
@@ -14,7 +14,6 @@ source="https://github.com/chaos/$pkgname/archive/$pkgname-$pkgver.tar.gz
without-rresvport.patch
fix-test-t6036.patch"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
-options="!checkroot"
prepare() {
default_prepare
diff --git a/community/repmgr/APKBUILD b/community/repmgr/APKBUILD
index 25a4b1481d..4dc0d4c2dc 100644
--- a/community/repmgr/APKBUILD
+++ b/community/repmgr/APKBUILD
@@ -12,12 +12,10 @@ makedepends="postgresql-dev flex libxml2-dev libedit-dev"
pkgusers="postgres"
pkggroups="postgres"
subpackages="$pkgname-doc $pkgname-daemon"
-source="$pkgname-$pkgver.tar.gz::https://github.com/2ndQuadrant/$pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/2ndQuadrant/repmgr/archive/v$pkgver.tar.gz
repmgr.conf.patch
repmgrd.initd
"
-builddir="$srcdir/$pkgname-$pkgver"
-options="!checkroot"
build() {
./configure
diff --git a/community/restic/APKBUILD b/community/restic/APKBUILD
index f72df0f61b..d20d47a8ce 100644
--- a/community/restic/APKBUILD
+++ b/community/restic/APKBUILD
@@ -8,11 +8,11 @@ url="https://restic.net/"
arch="all"
license="BSD-2-Clause"
makedepends="go"
-options="net !checkroot"
+options="net"
subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/restic/restic/releases/download/v$pkgver/restic-$pkgver.tar.gz"
builddir="$srcdir/src/github.com/$pkgname/$pkgname"
export GOPATH="$srcdir"
@@ -24,17 +24,14 @@ prepare() {
}
build() {
- cd "$builddir"
go build ./cmd/...
}
check() {
- cd "$builddir"
RESTIC_TEST_FUSE=0 make test
}
package() {
- cd "$builddir"
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
local man
diff --git a/community/tcsh/APKBUILD b/community/tcsh/APKBUILD
index f38c8b47f8..ecc4d3bc7f 100644
--- a/community/tcsh/APKBUILD
+++ b/community/tcsh/APKBUILD
@@ -12,7 +12,6 @@ checkdepends="diffutils autoconf"
makedepends="ncurses-dev"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
-options="!checkroot"
_tarball="TCSH6_21_00"
source="tcsh-$pkgver.tar.gz::https://github.com/tcsh-org/tcsh/archive/$_tarball.tar.gz
001-sysmalloc.patch
diff --git a/community/vlc/APKBUILD b/community/vlc/APKBUILD
index 05a442d90e..6a42838433 100644
--- a/community/vlc/APKBUILD
+++ b/community/vlc/APKBUILD
@@ -11,7 +11,6 @@ pkggroups="vlc"
url="https://www.videolan.org/vlc/"
arch="all !s390x"
license="GPL-2.0-or-later"
-options="!checkroot"
subpackages="$pkgname-dev
$pkgname-doc
$pkgname-qt
diff --git a/community/yadifa/APKBUILD b/community/yadifa/APKBUILD
index 6266d92eac..adc9eab394 100644
--- a/community/yadifa/APKBUILD
+++ b/community/yadifa/APKBUILD
@@ -10,7 +10,6 @@ arch="all"
license="BSD-3-Clause"
makedepends="openssl-dev"
install="$pkgname.post-install"
-options="!libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
source="http://cdn.yadifa.eu/sites/default/files/releases/yadifa-$pkgver-$_buildnr.tar.gz
musl-fixes.patch