aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/u-boot-s5p6818/APKBUILD28
-rw-r--r--testing/u-boot-s5p6818/kbuild.patch17
-rw-r--r--testing/u-boot-s5p6818/makefile.patch16
3 files changed, 61 insertions, 0 deletions
diff --git a/testing/u-boot-s5p6818/APKBUILD b/testing/u-boot-s5p6818/APKBUILD
new file mode 100644
index 0000000000..b39091bbda
--- /dev/null
+++ b/testing/u-boot-s5p6818/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=u-boot-s5p6818
+pkgver=1.2
+pkgrel=0
+pkgdesc="u-boot bootloader for Samsung Nexell S5P6818"
+url="https://github.com/rafaello7/u-boot-nanopi-m3"
+arch="aarch64"
+license="BSD-2-Clause"
+options="!check" # No test suite from upstream
+makedepends="bsd-compat-headers dtc"
+source="u-boot-s5p6818-$pkgver.tar.gz::https://github.com/rafaello7/u-boot-nanopi-m3/archive/v$pkgver.tar.gz
+ makefile.patch
+ kbuild.patch"
+builddir="$srcdir/u-boot-nanopi-m3-$pkgver"
+
+build() {
+ make nanopim3_defconfig
+ make
+}
+
+package() {
+ install -Dm755 -t "$pkgdir"/usr/share/u-boot/nanopi-m3/ u-boot.bin
+}
+
+sha512sums="96fb3ea3ec345c2e91095d43b788bac1cacc36cff26b702ceaf1284ce83769957e3e0edb685d2db40d70dfe29e16a4196c0b574fc19fc9b736f683e5881c0337 u-boot-s5p6818-1.2.tar.gz
+08de0f3d88f623f4ecb5d0b21bf16c232149de930744f9a541951e728b7e499144a37e44dcf6fa0827f72071a29c26187bfc9234399bf02c39e13fac9abd22a2 makefile.patch
+43ccd3d3fc737da39b01095f4501b02897499ae14b15d59f1bfef82c8fc18139cb3dea31620c37932d04ed22bbf2d83235680e0ff5d5fb0cd2e3824b71831678 kbuild.patch"
diff --git a/testing/u-boot-s5p6818/kbuild.patch b/testing/u-boot-s5p6818/kbuild.patch
new file mode 100644
index 0000000000..f14c0411d0
--- /dev/null
+++ b/testing/u-boot-s5p6818/kbuild.patch
@@ -0,0 +1,17 @@
+--- a/scripts/Kbuild.include 2017-12-06 09:44:35.000000000 -0600
++++ b/scripts/Kbuild.include 2019-05-03 18:52:42.000000000 -0500
+@@ -113,12 +113,12 @@
+ # Usage: cflags-y += $(call cc-option,-march=winchip-c6,-march=i586)
+
+ cc-option = $(call try-run,\
+- $(CC) -Werror $(KBUILD_CPPFLAGS) $(KBUILD_CFLAGS) $(1) -c -x c /dev/null -o "$$TMP",$(1),$(2))
++ $(CC) $(KBUILD_CPPFLAGS) $(KBUILD_CFLAGS) $(1) -c -x c /dev/null -o "$$TMP",$(1),$(2))
+
+ # cc-option-yn
+ # Usage: flag := $(call cc-option-yn,-march=winchip-c6)
+ cc-option-yn = $(call try-run,\
+- $(CC) -Werror $(KBUILD_CPPFLAGS) $(KBUILD_CFLAGS) $(1) -c -x c /dev/null -o "$$TMP",y,n)
++ $(CC) $(KBUILD_CPPFLAGS) $(KBUILD_CFLAGS) $(1) -c -x c /dev/null -o "$$TMP",y,n)
+
+ # cc-option-align
+ # Prefix align with either -falign or -malign
diff --git a/testing/u-boot-s5p6818/makefile.patch b/testing/u-boot-s5p6818/makefile.patch
new file mode 100644
index 0000000000..e62c633d12
--- /dev/null
+++ b/testing/u-boot-s5p6818/makefile.patch
@@ -0,0 +1,16 @@
+--- a/tools/fip_create/Makefile 2017-12-06 09:44:35.000000000 -0600
++++ b/tools/fip_create/Makefile 2019-05-03 18:51:24.000000000 -0500
+@@ -28,11 +28,11 @@
+ # POSSIBILITY OF SUCH DAMAGE.
+ #
+
+-HOST_EXTRACFLAGS = -Wall -Werror -pedantic -std=c99
++HOST_EXTRACFLAGS = -Wall -pedantic -std=c99
+ hostprogs-y := fip_create
+ fip_create-objs := fip_create.o
+
+-HOST_EXTRACFLAGS = -Wall -Werror -pedantic -std=c99
++HOST_EXTRACFLAGS = -Wall -pedantic -std=c99
+ ifeq (${DEBUG},1)
+ HOST_EXTRACFLAGS += -g -O0 -DDEBUG
+ else