aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/opam/APKBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 9fc68ba862..fd04e8252a 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -2,20 +2,18 @@
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=opam
pkgver=2.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
arch="all !x86 !armhf !armv7" # ocaml not avail on excluded platforms
license="LGPL-2.1"
-depends="ocaml curl xz tar unzip rsync patch bubblewrap bash"
+depends="ocaml curl tar unzip rsync patch bubblewrap bash"
makedepends="ocaml-compiler-libs"
-source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz"
+source="https://github.com/ocaml/opam/releases/download/$pkgver/opam-full-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-full-$pkgver"
subpackages="$pkgname-doc"
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,12 +28,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
check() {
- cd "$builddir"
make tests
}