aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/ocaml-obuild/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/ocaml-obuild/APKBUILD b/testing/ocaml-obuild/APKBUILD
new file mode 100644
index 0000000000..50f375e92d
--- /dev/null
+++ b/testing/ocaml-obuild/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Andy Li <andy@onthewings.net>
+# Maintainer: Andy Li <andy@onthewings.net>
+pkgname=ocaml-obuild
+_pkgname=obuild
+pkgver=0.1.10
+pkgrel=0
+pkgdesc="Simple package build system for ocaml"
+url="https://github.com/ocaml-obuild/obuild"
+arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
+license="BSD-2-Clause"
+depends="ocaml-runtime"
+makedepends="ocaml ocaml-findlib opam"
+options="!check" # no tests provided
+source="$pkgname-$pkgver.tar.gz::$url/archive/obuild-v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-obuild-v$pkgver"
+
+build() {
+ ./bootstrap
+}
+
+package() {
+ opam-installer -i \
+ --prefix="$pkgdir/usr" \
+ --libdir="$pkgdir/usr/lib/ocaml" \
+ $_pkgname.install
+
+ rm -rf "$builddir/dist"
+}
+
+sha512sums="23667213ec7de6610fd5b3c7e0c5f98c081d0244619ed0c833ad13647b9a40561f21e862574488454993eab84a8467f4b2caa3288293451bb54f08b92d280175 ocaml-obuild-0.1.10.tar.gz"