aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-flask/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/community/py3-flask/APKBUILD b/community/py3-flask/APKBUILD
index d668b0713d..3a67ac8c75 100644
--- a/community/py3-flask/APKBUILD
+++ b/community/py3-flask/APKBUILD
@@ -10,6 +10,7 @@ arch="noarch"
license="MIT"
depends="python3 py3-click py3-itsdangerous py3-jinja2 py3-werkzeug"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -17,12 +18,14 @@ replaces="py-flask" # Backwards compatibility
provides="py-flask=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ PYTHONPATH="$PWD/build/lib" py.test-3
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}