aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-ncclient/APKBUILD (renamed from testing/py-ncclient/APKBUILD)34
1 files changed, 7 insertions, 27 deletions
diff --git a/testing/py-ncclient/APKBUILD b/testing/py3-ncclient/APKBUILD
index 740429d309..8ddad99983 100644
--- a/testing/py-ncclient/APKBUILD
+++ b/testing/py3-ncclient/APKBUILD
@@ -1,49 +1,29 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
-pkgname=py-ncclient
+pkgname=py3-ncclient
+_pkgname=ncclient
pkgver=0.5.3
pkgrel=1
pkgdesc="Library for NETCONF clients"
url="https://github.com/tomchristie/itypes"
arch="noarch"
license="Apache-2.0"
-depends="py-paramiko py-lxml py-six"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-lxml py3-paramiko py3-setuptools py3-six"
options="!check" #no testsuite
source="$pkgname-$pkgver.tar.gz::https://github.com/ncclient/ncclient/archive/v$pkgver.tar.gz"
builddir="$srcdir"/ncclient-$pkgver
+replaces="py-ncclient" # Backwards compatibility
+provides="py-ncclient=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$builddir"
- python2 setup.py --quiet build
python3 setup.py --quiet build
}
package() {
cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- local pyver="${1:6:1}"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
}
sha512sums="53320a745dda98cd6e7c2e4cf87df446b90b74982543e529810225060c5774a4c3f2470a3d6e4fd84ad83cac11a4ea50b538a9a95c5d9cfd5c5714c693342217 py-ncclient-0.5.3.tar.gz"