aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/gcc/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index a2f7444a3e..f90cd60be5 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -369,10 +369,7 @@ package() {
mv "$pkgdir"/usr/lib/*-gdb.py \
"$pkgdir"/usr/share/gdb/python/auto-load/usr/lib/
- # only paxmark if cross-compiling, otherwise paxctl fails
- if [ "$CBUILD" = "$CTARGET" ]; then
- paxmark -pmrs "$pkgdir"/$_gcclibexec/cc1 || return 1
- fi
+ paxmark -pmrs "$pkgdir"/$_gcclibexec/cc1 || return 1
# move ada runtime libs
if $LANG_ADA; then