aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libretro-daphne/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/libretro-daphne/APKBUILD b/testing/libretro-daphne/APKBUILD
new file mode 100644
index 0000000000..ea26a174ba
--- /dev/null
+++ b/testing/libretro-daphne/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-daphne
+pkgver=0_git20200914
+pkgrel=0
+_commit="7e5cac88d0509c6f4722100c5b8a9b5ee91f404a"
+pkgdesc="daphne core for libretro"
+url="https://github.com/libretro/daphne"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="zlib-dev"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/daphne/archive/$_commit.tar.gz"
+builddir="$srcdir/daphne-$_commit"
+options="!check" # No tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm644 daphne_libretro.so "$pkgdir"/usr/lib/libretro/daphne_libretro.so
+}
+
+sha512sums="f66e4effb9080d9f44f076ae35174531f9cc375f3df6572745acce05f094098f4cee7a331dcf44b9c8e46133d236f0097a6256ff413da8f7dd214d0cd28194b1 libretro-daphne-7e5cac88d0509c6f4722100c5b8a9b5ee91f404a.tar.gz"