aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/perl-filesys-notify-simple/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/main/perl-filesys-notify-simple/APKBUILD b/main/perl-filesys-notify-simple/APKBUILD
index 51bf825353..2639b03b43 100644
--- a/main/perl-filesys-notify-simple/APKBUILD
+++ b/main/perl-filesys-notify-simple/APKBUILD
@@ -1,35 +1,31 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-filesys-notify-simple
-pkgver=0.13
+pkgver=0.14
pkgrel=0
pkgdesc="Filesys::Notify::Simple perl module"
-url="http://search.cpan.org/dist/Filesys-Notify-Simple/"
+url="https://metacpan.org/release/Filesys-Notify-Simple"
arch="noarch"
-license="GPL-2.0 or Artistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
checkdepends="perl-test-sharedfork"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Filesys-Notify-Simple-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/M/MI/MIYAGAWA/Filesys-Notify-Simple-$pkgver.tar.gz"
builddir="$srcdir/Filesys-Notify-Simple-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="e8c02428240687d34c7ade45a893baecdd6cfc77e4730d3fe07d2009c7ac441512c494cfd139002b7e49ae2b23cc6323da3903004262930adc89f21077960c88 Filesys-Notify-Simple-0.13.tar.gz"
+sha512sums="45fe097beb925e913af9c48704f5f550931c70673455258249127dff27abe1955e0e968f37c7c0f4c798a20be78b1055362c69ec2906e8e2633b21f68b198208 Filesys-Notify-Simple-0.14.tar.gz"