aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/php/APKBUILD14
-rw-r--r--main/php/fix-crypt-sha.patch20
-rw-r--r--main/php/fix-crypt.patch (renamed from main/php/php-fix-crypt.patch)19
3 files changed, 18 insertions, 35 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index ed51b151e4..f32efde312 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=php
pkgver=5.6.19
-pkgrel=0
+pkgrel=1
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
@@ -113,8 +113,7 @@ source="http://php.net/distributions/php-$pkgver.tar.bz2
php5-module.conf
php-install-pear-xml.patch
gd-iconv.patch
- php-fix-crypt.patch
- fix-crypt-sha.patch
+ fix-crypt.patch
"
_apiver="20131106"
@@ -498,19 +497,16 @@ md5sums="aec4374c660d7b160497001c25f8c75e php-5.6.19.tar.bz2
67719f428f44ec004da18705cbabe2ee php5-module.conf
483bc0a85c50a9a9aedbe14a19ed4526 php-install-pear-xml.patch
162d8d079944387eab2bc80edab347ae gd-iconv.patch
-b63ef63893c1c115d6dd63e8df1f17e3 php-fix-crypt.patch
-cb10034c525c6544890f1a1839837e38 fix-crypt-sha.patch"
+91de1566b540d629fa058f1145415740 fix-crypt.patch"
sha256sums="2a24a3f84971680ac0a4c71050067de4f76ee235aa4a041fae21bfa69975c168 php-5.6.19.tar.bz2
3ad0252894d628e9832dbefb24d7043ac0f75475cd26d6ca12332e71cc3fc0f5 php-fpm.initd
ceec4d5b2a128c6a97e49830af604f0bb555bca1a86a9cd0366b828ba392257f php5-module.conf
f739ca427a1dd53a388bad0823565299c5d4a5796b1171b892884e4d7d099bab php-install-pear-xml.patch
6122bf279cdb7c387dd000761b2426969a73cf63a10a132aa98a79eb1dd259b2 gd-iconv.patch
-817f6300cd0c4d97f24c3e883132d2cde0ef52d84f5c97073f9c9668d6275d6e php-fix-crypt.patch
-a5db307ad2638e7e609b450abce19c98c23de54be96619b46adb69f2c5e11fa2 fix-crypt-sha.patch"
+0166b8bad6ded93fdb5a960eeabe970e2ade68b2159061dd75849e43a8e98e2d fix-crypt.patch"
sha512sums="c8c2b3bdfc1a8abe834612c33123b4f103e841c230b53934fb7bafe11af7f1175f02ca54c92f33e8e603485e6283897bebb51acc55d1213b7433024684215c14 php-5.6.19.tar.bz2
38c24e84c9be2dcf4f291e5f04187f40e5a8b325da73e79580d82b8a9e0e496c4fb17df92dcf8157bb9df4f1beadce102df9265c83849ca4e55560abf4937c43 php-fpm.initd
895e94c791bd82060ad820fef049d366a09c932097faa6b7b9a2c2e9e00a18cb7c0f9b128679c7659b404379266fd0f95dba5c0333f626194cf60f7bf6044102 php5-module.conf
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 php-install-pear-xml.patch
59443fb464f49ff7d9b64739df982e7240f9d4792226d96ad1538286945125fc7eb6f0cab88b64d5c81ee3679fd89bffdca59ebd20eca2778ab801ee54529028 gd-iconv.patch
-febe75305b19ca7c2b4f85ee8144d3a347530044223619b28fb754485f72fe3dd283ece341d77f2e0bff3881ed7fa2b89e6c95a8e4b077ab40b3f7a8d767a633 php-fix-crypt.patch
-d3b156dc7fca33c5634ace04bc7b7f27174d58d09455adf5bcdafd748a6aab1b1c97dce588d218b95d5fde3f6c2dd9202f4d7ea1c3b323be400f4d990c39290b fix-crypt-sha.patch"
+7b1a3a0c586afb19d53561acd75ae591c26a77fa0e38117467dba811b235f77ad87c0867ad61567e4666ef9891ce9140102bc77b297b777bcaaa39027617f327 fix-crypt.patch"
diff --git a/main/php/fix-crypt-sha.patch b/main/php/fix-crypt-sha.patch
deleted file mode 100644
index db05584ead..0000000000
--- a/main/php/fix-crypt-sha.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./ext/standard/config.m4.orig
-+++ ./ext/standard/config.m4
-@@ -314,7 +314,7 @@
- fi
- AC_DEFINE_UNQUOTED(PHP_MD5_CRYPT, $ac_result, [Whether the system supports MD5 salt])
-
-- if test "$ac_cv_crypt_sha512" = "yes"; then
-+ if test "$ac_cv_crypt_SHA512" = "yes"; then
- ac_result=1
- ac_crypt_sha512=1
- else
-@@ -323,7 +323,7 @@
- fi
- AC_DEFINE_UNQUOTED(PHP_SHA512_CRYPT, $ac_result, [Whether the system supports SHA512 salt])
-
-- if test "$ac_cv_crypt_sha256" = "yes"; then
-+ if test "$ac_cv_crypt_SHA256" = "yes"; then
- ac_result=1
- ac_crypt_sha256=1
- else
diff --git a/main/php/php-fix-crypt.patch b/main/php/fix-crypt.patch
index caa6a2e22d..2b6b1d3011 100644
--- a/main/php/php-fix-crypt.patch
+++ b/main/php/fix-crypt.patch
@@ -1,9 +1,16 @@
-Reported upstream:
https://bugs.php.net/bug.php?id=67512
---- php-5.5.13/ext/standard/crypt.c.orig 2014-06-25 13:10:38.930010191 -0300
-+++ php-5.5.13/ext/standard/crypt.c 2014-06-25 13:45:09.762124864 -0300
-@@ -228,18 +228,20 @@
+--- php-5.6.19.orig/ext/standard/crypt.c
++++ php-5.6.19/ext/standard/crypt.c
+@@ -58,6 +58,7 @@
+ #include "php_lcg.h"
+ #include "php_crypt.h"
+ #include "php_rand.h"
++#include "php_config.h"
+
+ /* The capabilities of the crypt() function is determined by the test programs
+ * run by configure from aclocal.m4. They will set PHP_STD_DES_CRYPT,
+@@ -227,18 +228,20 @@
}
}
#else
@@ -28,10 +35,10 @@ https://bugs.php.net/bug.php?id=67512
+# else
+ crypt_res = crypt(passwrd, salt);
+#endif
- if (!crypt_res || (salt[0] == '*' && salt[1] == '0')) {
+ if (!crypt_res || (salt[0] == '*' && salt[1] == '0')) {
return FAILURE;
} else {
-@@ -247,7 +249,6 @@
+@@ -246,7 +249,6 @@
return SUCCESS;
}
}