aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/kimchi/APKBUILD101
-rw-r--r--testing/kimchi/alpine-specific-kimchi.api.patch23
-rw-r--r--testing/kimchi/systemd-substitution-with-openrc.patch18
3 files changed, 48 insertions, 94 deletions
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index 46db425273..a7a4eca756 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -1,85 +1,80 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kimchi
-pkgver=2.5.0
-pkgrel=2
+pkgver=3.0.0
+pkgrel=0
pkgdesc="An HTML5 management interface for KVM"
url="https://github.com/kimchi-project/kimchi"
-arch="noarch !armv7 !mips !mips64" # Missing py2-pyldap
-license="Apache LGPL-2.1"
+arch="noarch"
+license="Apache-2.0 and LGPL-2.1-or-later"
depends="
- python2
- py-ipaddr
- py2-m2crypto
- py2-simplejson
- py-psutil
- py-imaging
- py2-libvirt
- py-cheetah
- py-ethtool
- py2-lxml
- py2-websockify>=0.8.0-r2
- py2-pillow
+ gingerbase
+ libvirt-daemon
+ novnc>=1.0.0-r1
+ py3-cheetah
+ py3-configobj
+ py3-ethtool
+ py3-ipaddr
+ py3-libuser
+ py3-libvirt
+ py3-lxml
+ py3-m2crypto
+ py3-magic
+ py3-netaddr
+ py3-numpy
+ py3-paramiko
+ py3-pillow
+ py3-psutil
+ py3-simplejson
+ py3-six
+ py3-yaml
+ python3
qemu
qemu-img
- py2-configobj
- py2-six
- py2-paramiko
- py2-magic
- libvirt-daemon
- wok
- gingerbase
- py2-netaddr
- py2-libuser
- util-linux
spice-html5
+ util-linux
websockify>=0.8.0-r2
- py-numpy
- novnc>=1.0.0-r1
+ wok>=3.0.0-r0
"
makedepends="
- automake
autoconf
- libtool
-
- gettext-dev
- python2-dev
- py-setuptools
- pyflakes
- libxslt py2-pip
- py-pep8
- py2-mock
- py-cherrypy
- pytest
- py2-requests
- grep
+ automake
bash
bc
+ gettext-dev
+ grep
+ libtool
+ libxslt
+ py3-cherrypy
+ py3-mock
+ py3-pip
+ py3-pyflakes
+ py3-pytest
+ py3-requests
+ py3-setuptools
+ python3-dev
spice-html5
"
-options="!check"
+options="!check" # depends on jaraco
subpackages="$pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
- alpine-specific-kimchi.api.patch
- systemd-substitution-with-openrc.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/kimchi/archive/$pkgver.tar.gz"
build() {
- cd "$builddir"
sh ./autogen.sh --system
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--with-spice-html5
- make -j1
+ make
+}
+
+check() {
+ make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="dd321db999f58e67b2dd88e58598ba360aaba3a4eb517a19a97bfb12ca27ded2273b1400359c601a8184c845e45ed1dbbcc54e25e65fcc59f5496d1d509fd135 kimchi-2.5.0.tar.gz
-402ccb180ae283c38dea44ef03ed563e401d87f741473a6fa4c582845f21f8e37bf506d66ca45e0e5e6982aa4f26a21452ac98d6ca7cffaba68c8d744e47505e alpine-specific-kimchi.api.patch
-a78c51237233b629c84106cfcdc8398a030889dd8bc641630a8c4e05fdad8d32a9b457c36188e1752a1277ef884437c1765c897bc2a33ca87c07e3bafdfdd5bf systemd-substitution-with-openrc.patch"
+sha512sums="0a10a4eb5a08d3bb9e16e9388031a1f01623aa150a66abcb7e25abac065151979777bfdc880ed9c200b028649766234776a64336c2a2e3a67f0d858d0afcda66 kimchi-3.0.0.tar.gz"
diff --git a/testing/kimchi/alpine-specific-kimchi.api.patch b/testing/kimchi/alpine-specific-kimchi.api.patch
deleted file mode 100644
index 1260c18194..0000000000
--- a/testing/kimchi/alpine-specific-kimchi.api.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/ui/js/src/kimchi.api.js
-+++ b/ui/js/src/kimchi.api.js
-@@ -324,7 +324,7 @@
- url += server_root;
- url += "/plugins/kimchi/serial/html/serial.html";
- url += "?port=" + proxy_port;
-- url += "&path=" + server_root + "/websockify";
-+ url += "&path=" + server_root + "websockify";
- url += "?token=" + wok.urlSafeB64Encode(vm+'-console').replace(/=*$/g, "");
- url += '&encrypt=1';
- window.open(url);
-@@ -346,9 +346,9 @@
- }).done(function() {
- url = 'https://' + location.hostname + ':' + proxy_port;
- url += server_root;
-- url += "/plugins/kimchi/novnc/vnc_auto.html";
-+ url += "/plugins/kimchi/novnc/vnc_lite.html";
- url += "?port=" + proxy_port;
-- url += "&path=" + server_root + "/websockify";
-+ url += "&path=" + server_root + "websockify";
- /*
- * From python documentation base64.urlsafe_b64encode(s)
- * substitutes - instead of + and _ instead of / in the
diff --git a/testing/kimchi/systemd-substitution-with-openrc.patch b/testing/kimchi/systemd-substitution-with-openrc.patch
deleted file mode 100644
index b05f545530..0000000000
--- a/testing/kimchi/systemd-substitution-with-openrc.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/utils.py b/utils.py
-index 22430ce..2ec4845 100644
---- a/utils.py
-+++ b/utils.py
-@@ -265,9 +265,11 @@ def is_libvirtd_up():
- """
- Checks if libvirtd.service is up.
- """
-- cmd = ['systemctl', 'is-active', 'libvirtd.service']
-+ cmd = ['rc-service', 'is-active', 'libvirtd.service']
-+ cmd = ['rc-service', 'libvirtd', 'status']
- output, error, rc = run_command(cmd, silent=True)
-- return True if output == 'active\n' else False
-+ return True if "started" in output else False
-+
-
-
- def is_s390x():